summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-23 19:53:55 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:58 +0000
commit3c2943b621c05899aa59f0932b8e1d1053869db1 (patch)
tree22f9feccdedc63c07f972f2de6be05c88f7d2cde
parent5f49430d303a88407c71506f5a7dac8eb8f877cf (diff)
gnu: build-system/pyproject: Add missing native-inputs.
* gnu/packages/bioinformatics.scm (python-ega-download-client) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/databases.scm (datasette)[native-inputs]: Add python-pip. * gnu/packages/django.scm (python-django-localflavor, python-django-contact-form)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/jupyter.scm (python-jupyterlab-server)[native-inputs]: Add python-wheel. (python-nbstripout)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/machine-learning.scm (python-captum, python-linear-operator, python-gpytorch)[native-inputs]: Add python-setuptools. * gnu/packages/music.scm (abjad, abjad-ext-rmarkers, abjed-ext-nauert, python-mutagen)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/package-management.scm (python-conda-package-handling)[native-inputs]: Add python-setuptools and python-wheel. (conda)[native-inputs]: Add python-wheel. * gnu/packages/python-check.scm (python-pyinstrument, python-pytest-testmon, python-pytest-trio, python-nbval, python-pytest-toolbox)[native-inputs]: Add python-setuptools and python-wheel. (python-nptyping)[native-inputs]: Add python-setuptools. * gnu/packages/python-check.scm (python-dask-expr)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-web.scm (parfive, python-aioftp, python-hupper, python-sanic, python-mechanicalsoup, python-tinycss, python-aiostream, python-cbor2, gunicorn)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-xyz.scm (python-apprise, python-jaraco-classes, python-sparse, python-shtab, python-pyan3)[native-inputs]: Add python-setuptools. (python-jupytext, python-orderedmultidict, python-identify, python-nodeenv, python-cfgv, python-zarr, python-multipart, python-nbconvert, python-cram, python-immutables, python-numpydoc, python-cairosvg, python-unidecode, python-black, python-multidict, python-mpv-jsonipc, python-humanize, python-cmd2)[native-inputs]: Add python-setuptools and python-wheel. (python-partd, python-dask, python-zarr)[native-inputs]: Add python-wheel. (python-nbconvert)[propagated-inputs]: Add texlive-etoolbox. Remove duplicate textlive-jknapltx. (python-isort)[native-inputs]: Add python-pip. * gnu/packages/simulation.scm (python-fenics-dijitso)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/sphinx.scm (python-pydata-sphinx-theme, python-sphinx-autodoc-typehints)[native-inputs]: Add python-setuptools. * gnu/packages/syndication.scm (tuir)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/terminals.scm (python-halo)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/time.scm (python-arrow, python-dateutil) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/version-control.scm (pre-commit)[native-inputs]: Add python-setuptools and python-wheel. Remove input labels. * gnu/packages/virtualization.scm (python-qemu-qmp, python-transient)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/xorg.scm (python-xcffib)[native-inputs]: Add python-setuptools and python-wheel. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: Id61cf8cdc47bd4c2871c0a9c8e9a5bfd51157df0
-rw-r--r--gnu/packages/bioinformatics.scm10
-rw-r--r--gnu/packages/databases.scm1
-rw-r--r--gnu/packages/django.scm2
-rw-r--r--gnu/packages/graphviz.scm4
-rw-r--r--gnu/packages/jupyter.scm7
-rw-r--r--gnu/packages/machine-learning.scm5
-rw-r--r--gnu/packages/music.scm12
-rw-r--r--gnu/packages/package-management.scm12
-rw-r--r--gnu/packages/python-check.scm27
-rw-r--r--gnu/packages/python-science.scm4
-rw-r--r--gnu/packages/python-web.scm52
-rw-r--r--gnu/packages/python-xyz.scm84
-rw-r--r--gnu/packages/simulation.scm2
-rw-r--r--gnu/packages/sphinx.scm4
-rw-r--r--gnu/packages/syndication.scm4
-rw-r--r--gnu/packages/terminals.scm10
-rw-r--r--gnu/packages/time.scm13
-rw-r--r--gnu/packages/version-control.scm18
-rw-r--r--gnu/packages/virtualization.scm10
-rw-r--r--gnu/packages/xorg.scm8
20 files changed, 215 insertions, 74 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b22d2ffb57..f1d44d870a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3285,8 +3285,14 @@ the managed genomes, STAR indexing and mapping and more.")
(("==") ">=")))))))
(propagated-inputs (list python-htsget python-psutil python-requests
python-tqdm python-urllib3))
- (native-inputs (list python-coverage python-pytest python-pyfakefs
- python-responses python-mock))
+ (native-inputs
+ (list python-coverage
+ python-mock
+ python-pyfakefs
+ python-pytest
+ python-responses
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/EGA-archive/ega-download-client")
(synopsis "EGA download client")
(description "PyEGA3 is a tool for viewing and downloading files from
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 323e74534c..9508593b26 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5713,6 +5713,7 @@ mechanism of @code{dogpile}.")
(list python-beautifulsoup4
python-black
python-cogapp
+ python-pip
python-pytest
python-pytest-asyncio
python-pytest-runner
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index cba9383d42..79ce4130d2 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -299,6 +299,8 @@ commands, additional database fields and admin extensions.")
(if tests?
(apply invoke "python" "-m" "django" "test" test-flags)
(format #t "test suite not run~%")))))))
+ (native-inputs
+ (list python-setuptools python-wheel))
(propagated-inputs
(list python-django python-stdnum))
(home-page "https://django-localflavor.readthedocs.io/en/latest/")
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 8ff09fe232..10fde9c943 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -221,7 +221,9 @@ and not test_sphinx_book_text_broken_strict")))
python-isort
python-mypy
python-pytest
- python-pytest-cov))
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-black python-sphinx-5 python-unidecode
(package/inherit python-sphinx-rtd-theme
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 2c9dd6d71c..60c61ffc10 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -436,7 +436,8 @@ the JupyterLab CSS variables.")
python-requests-mock
python-ruamel.yaml
python-strict-rfc3339
- python-werkzeug))
+ python-werkzeug
+ python-wheel))
(home-page "https://jupyter.org")
(synopsis "Server components for JupyterLab applications")
(description "JupyterLab Server sits between JupyterLab and Jupyter
@@ -878,7 +879,9 @@ nbshow present a single notebook in a terminal-friendly way
(list python-pytest
python-pytest-cram
python-pytest-flake8
- python-pytest-runner))
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/kynan/nbstripout")
(synopsis "Strips outputs from Jupyter and IPython notebooks")
(description
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 0d96a03faa..8b6e64cb98 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5121,7 +5121,8 @@ Actions for the Lightning suite of libraries.")
python-parameterized
python-pytest
python-pytest-cov
- python-scikit-learn))
+ python-scikit-learn
+ python-setuptools))
(home-page "https://captum.ai")
(synopsis "Model interpretability for PyTorch")
(description "Captum is a model interpretability and understanding library
@@ -5692,6 +5693,7 @@ inference.")
(native-inputs (list python-flake8
python-flake8-print
python-pytest
+ python-setuptools
python-setuptools-scm
python-twine))
(home-page "https://github.com/cornellius-gp/linear_operator/")
@@ -5724,6 +5726,7 @@ linear algebra routines needed for structured matrices (or operators).")
python-flake8-print
python-nbval
python-pytest
+ python-setuptools
python-twine))
(home-page "https://gpytorch.ai")
(synopsis "Implementation of Gaussian Processes in PyTorch")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 78f20166e5..20c6636559 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1811,7 +1811,7 @@ listeners answer questions about music quickly and simply.")
(inputs
(list lilypond))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-quicktions
python-ply
@@ -1843,7 +1843,7 @@ typographic detail of symbols on the page.")
(base32 "1y8s55b4mlsigm0xkk6qjpp08c75rv0swvjp0lj3cs6lgqdjxdjl"))))
(build-system pyproject-build-system)
(native-inputs
- (list lilypond python-pytest))
+ (list lilypond python-pytest python-setuptools python-wheel))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -1868,7 +1868,7 @@ and manipulating rhythms such as accelerandi, taleas, and more.")
(base32 "0j4pf4h27jm3df0dn2rwkdx6zqcxvr7pqchbaa9rffz7q4hbakmf"))))
(build-system pyproject-build-system)
(native-inputs
- (list lilypond python-pytest))
+ (list lilypond python-pytest python-setuptools python-wheel))
(propagated-inputs
(list abjad))
(home-page "https://abjad.github.io")
@@ -4074,7 +4074,11 @@ formats, looking up tracks through metadata and audio fingerprints.")
(("( +)@given" all spaces)
(string-append spaces "@settings(deadline=None)\n" all))))))))
(native-inputs
- (list python-pytest python-hypothesis python-flake8))
+ (list python-flake8
+ python-hypothesis
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://mutagen.readthedocs.io/")
(synopsis "Read and write audio tags")
(description "Mutagen is a Python module to handle audio metadata. It
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index e56deb5810..29ebc35e3b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1139,8 +1139,13 @@ environments.")
(inputs
(list libarchive))
(native-inputs
- (list python-cython python-pytest python-pytest-cov
- python-pytest-mock python-mock))
+ (list python-cython
+ python-mock
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock
+ python-setuptools
+ python-wheel))
(home-page "https://conda.io")
(synopsis "Create and extract conda packages of various formats")
(description
@@ -1280,7 +1285,8 @@ extracting, creating, and converting between formats.")
(list python-coverage
python-flaky
python-pytest-timeout
- python-pytest-xprocess))
+ python-pytest-xprocess
+ python-wheel))
(home-page "https://github.com/conda/conda")
(synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
(description
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index aa915731fd..353acaac26 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -467,7 +467,9 @@ result documents that can be read by tools such as Jenkins or Bamboo.")
python-greenlet
python-pytest
python-pytest-asyncio
- python-pytest-trio))
+ python-pytest-trio
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/joerick/pyinstrument")
(synopsis "Call stack profiler for Python")
(description
@@ -1299,7 +1301,11 @@ simpler.")
(base32 "01qhbkb3n8c5c4id94w6b06q9wb7b6a33mqwyrkdfzk5pzv1gcyd"))))
(build-system pyproject-build-system)
(arguments (list #:tests? #false)) ;there are none
- (native-inputs (list python-coverage python-pytest))
+ (native-inputs
+ (list python-coverage
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/tarpas/pytest-testmon")
(synopsis "Selects tests affected by changed files and methods")
(description
@@ -1328,7 +1334,11 @@ simpler.")
;; No keyboard interrupt in our build environment.
" and not test_actual_test"))))
(native-inputs
- (list python-hypothesis python-pytest python-pytest-cov))
+ (list python-hypothesis
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-async-generator python-outcome python-pytest python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
@@ -1617,7 +1627,11 @@ service processes for your tests with pytest.")
(substitute* "setup.cfg"
((".*timeout.*") ""))))))))
(native-inputs
- (list python-pydantic python-pytest python-pytest-isort))
+ (list python-pydantic
+ python-pytest
+ python-pytest-isort
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/samuelcolvin/pytest-toolbox")
(synopsis "Numerous useful plugins for Pytest")
(description
@@ -1708,7 +1722,9 @@ notebooks.")
(native-inputs
(list python-pytest
python-pytest-cov
- python-sympy))
+ python-setuptools
+ python-sympy
+ python-wheel))
(propagated-inputs
(list python-coverage
python-ipykernel
@@ -2229,6 +2245,7 @@ them using any Python VM with basically no runtime overhead.")
(native-inputs
(list python-beartype
python-mypy
+ python-setuptools
python-typeguard
python-wheel))
(propagated-inputs (list python-numpy python-typing-extensions))
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 114af38814..918a127f07 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2467,7 +2467,9 @@ parentdir_prefix = dask_expr-
;; package without creating a mutually recursive dependency.
(list python-dask/bootstrap
python-pytest
- python-versioneer))
+ python-setuptools
+ python-versioneer
+ python-wheel))
(home-page "https://github.com/dask/dask-expr")
(synopsis "Dask DataFrames with query optimization")
(description "This is a rewrite of Dask DataFrame that includes query
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5367d132b0..47d5011487 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -706,7 +706,9 @@ comes with a SOCKS proxy client.")
(list python-pytest
python-pytest-asyncio
python-pytest-cov
- python-pytest-runner))
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/vxgmichel/aiostream")
(synopsis "Generator-based operators for asynchronous iteration")
(description "@code{aiostream} provides a collection of stream operators that can
@@ -1038,7 +1040,12 @@ to the OVHcloud APIs.")
(sha256
(base32 "15y78xcc3zkmvj1mdzz8gyhf3apbl91073kwhzbjk5abc1civwlw"))))
(build-system pyproject-build-system)
- (native-inputs (list python-pytest python-pytest-cov python-setuptools-scm))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/agronholm/cbor2")
(synopsis "Concise Binary Object Representation (CBOR) (de)serializer")
(description "This Python library provides encoding and decoding for the
@@ -1447,7 +1454,9 @@ HTTP servers, RESTful APIs, and web services.")
python-pytest-cov
python-pytest-localserver
python-pytest-socket
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://parfive.readthedocs.io/")
(synopsis "HTTP and FTP parallel file downloader")
(description
@@ -1634,7 +1643,9 @@ object graph to and from JSON.")
python-pytest-httpbin
python-pytest-mock
python-pytest-runner
- python-requests-mock))
+ python-requests-mock
+ python-setuptools
+ python-wheel))
(home-page "https://mechanicalsoup.readthedocs.io/")
(synopsis "Python library for automating website interaction")
(description
@@ -3924,9 +3935,14 @@ adapter for use with the Requests library.")
(base32
"0w621mg956m9rn7v39jpwi4gpnpl90pprwl29cp640dahqqv38ms"))))
(build-system pyproject-build-system)
- (native-inputs (list python-async-timeout python-pytest
- python-pytest-asyncio python-pytest-cov
- python-trustme))
+ (native-inputs
+ (list python-async-timeout
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-setuptools
+ python-trustme
+ python-wheel))
(propagated-inputs (list python-siosocks))
(home-page "https://aioftp.readthedocs.io/")
(synopsis "FTP client/server for asyncio in Python")
@@ -6222,8 +6238,12 @@ the non-map-specific features. It can be used to generate HTML + JS.")
(list #:test-flags
'(list "-k" "not test_speedups")))
(native-inputs
- (list python-pytest-cov python-pytest-flake8 python-pytest-isort
- python-pytest-runner))
+ (list python-pytest-cov
+ python-pytest-flake8
+ python-pytest-isort
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://tinycss.readthedocs.io/")
(synopsis "Complete yet simple CSS parser for Python")
(description
@@ -6443,6 +6463,7 @@ event loop. It is implemented in Cython and uses libuv under the hood.")
python-pytest-cov
python-sphinx
texinfo))
+ (propagated-inputs (list python-packaging python-setuptools python-wheel))
(home-page "https://gunicorn.org/")
(synopsis "Python WSGI HTTP Server for UNIX")
(description "Gunicorn ‘Green Unicorn’ is a Python WSGI HTTP
@@ -7254,8 +7275,13 @@ according to the standard set by PasteDeploy")
(build-system python-build-system)
(arguments '(#:test-target "pytest"))
(native-inputs
- (list python-pytest python-pytest-runner python-watchdog python-mock
- python-pytest-cov))
+ (list python-mock
+ python-pytest
+ python-pytest-cov
+ python-pytest-runner
+ python-setuptools
+ python-watchdog
+ python-wheel))
(propagated-inputs
(list python-pytz))
(home-page "https://readthedocs.org/projects/hupper")
@@ -8046,11 +8072,13 @@ applications.")
python-pytest-benchmark
python-pytest-sanic
python-sanic-testing
+ python-setuptools
python-slotscheck
python-towncrier
python-tox
python-types-ujson
- python-uvicorn))
+ python-uvicorn
+ python-wheel))
(home-page "https://github.com/sanic-org/sanic/")
(synopsis "Async Python web server/framework")
(description
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d958307806..e8a7c69277 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -342,6 +342,7 @@
python-pytest-cov
python-pytest-mock
python-pytest-xdist
+ python-setuptools
python-wheel))
(home-page "https://github.com/caronc/apprise")
(synopsis
@@ -572,8 +573,10 @@ design}.")
python-isort
python-ipython-genutils
python-jupyter-server
+ python-pyaml
python-pytest
- python-pyaml))
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-markdown-it-py
python-mdit-py-plugins
@@ -6251,6 +6254,7 @@ Capabilities include:
(base32
"1x620s4dk4d501pivhlfzbi2d1r5fnm9cssqwkn76f7d8sfk9nyg"))))
(build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://pypi.org/project/Unidecode/")
(synopsis "ASCII transliterations of Unicode text")
(description
@@ -8570,7 +8574,11 @@ and integrated feature-set for programming Python effectively.")
python-typed-ast
python-typing-extensions))
(native-inputs
- (list python-pytest python-pytest-aiohttp python-setuptools-scm))
+ (list python-pytest
+ python-pytest-aiohttp
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/psf/black")
(synopsis "The uncompromising code formatter")
(description "Black is the uncompromising Python code formatter.")
@@ -9073,8 +9081,12 @@ objects.")
(propagated-inputs
(list python-numba python-numpy python-scipy))
(native-inputs
- (list python-dask python-importlib-metadata python-pytest
- python-pytest-black python-pytest-cov))
+ (list python-dask
+ python-importlib-metadata
+ python-pytest
+ python-pytest-black
+ python-pytest-cov
+ python-setuptools))
(home-page "https://github.com/pydata/sparse/")
(synopsis "Library for multi-dimensional sparse arrays")
(description
@@ -9476,7 +9488,12 @@ parse and apply unified diffs. It has features such as:
;; TODO: unclear why these fail.
"-k" "not test_MyClass and not test_my_function")))
(propagated-inputs (list python-jinja2 python-sphinx))
- (native-inputs (list python-matplotlib python-pytest python-pytest-cov))
+ (native-inputs
+ (list python-matplotlib
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(home-page "https://pypi.org/project/numpydoc/")
(synopsis "Numpy's Sphinx extensions")
(description "Sphinx extension to support docstrings in Numpy format.")
@@ -10229,7 +10246,7 @@ e.g. copy examples, fetch data, etc.")
"1kjrxav572j45xvr1iy60zb2g8zqvrinzdkl4ax36js4vczckl8d"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-pytest-cov))
+ (list python-pytest python-pytest-cov python-setuptools python-wheel))
(home-page "https://github.com/aio-libs/multidict/")
(synopsis "Multidict implementation")
(description "Multidict is dict-like collection of key-value pairs
@@ -10250,7 +10267,7 @@ where key might be occurred more than once in the container.")
(propagated-inputs
(list python-six))
(native-inputs
- (list python-flake8 python-pycodestyle))
+ (list python-flake8 python-pycodestyle python-setuptools python-wheel))
(home-page "https://github.com/gruns/orderedmultidict")
(synopsis "Python Ordered Multivalue Dictionary - omdict")
(description "This package contains a library for ordered multivalue
@@ -12112,6 +12129,7 @@ enforced method signatures and consistent documentation.")
python-pytest-cov
python-pytest-flake8
python-pytest-mypy
+ python-setuptools
python-setuptools-scm
python-wheel))
(propagated-inputs (list python-more-itertools))
@@ -15624,7 +15642,7 @@ pseudo terminal (pty), and interact with both the process and its pty.")
(invoke "make" "test"))))))
(build-system python-build-system)
(native-inputs
- (list python-coverage which))
+ (list python-coverage python-setuptools python-wheel which))
(synopsis "Simple testing framework for command line applications")
(description
"Cram is a functional testing framework for command line applications.
@@ -16386,8 +16404,9 @@ distribution. It is not intended as an end-user tool.")
(uri (pypi-uri "immutables" version))
(sha256
(base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
- (build-system python-build-system)
- (native-inputs (list python-mypy python-pytest))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-mypy python-pytest python-setuptools python-wheel))
(home-page "https://github.com/MagicStack/immutables")
(synopsis "High-performance immutable mapping type for Python")
(description
@@ -18079,6 +18098,7 @@ time.")
texlive-collection-basic
texlive-enumitem
texlive-environ
+ texlive-etoolbox
texlive-eurosym
texlive-etoolbox
texlive-fancyvrb
@@ -18089,7 +18109,6 @@ time.")
texlive-hyperref
texlive-infwarerr
texlive-jknapltx
- texlive-jknapltx
texlive-kvoptions
texlive-lm
texlive-lm-math
@@ -24970,6 +24989,7 @@ package attempts to address the shortcomings of @code{isodate}.")
python-hypothesmith
python-libcst-minimal
python-natsort
+ python-pip
python-poetry-core
python-pylama
python-pypa-build
@@ -27750,6 +27770,7 @@ submitting it.")
(sha256
(base32 "0ymdwrx544a6gn6wm9dixpgzbfrbpxvcj5ys7m41cgb4lvpvx691"))))
(build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/iwalton3/python-mpv-jsonipc")
(synopsis "Python API to control MPV using JSON IPC")
(description "Python MPV JSONIPC implements an interface similar to
@@ -28375,7 +28396,7 @@ library to allow local file system access via @code{file://} URLs.")
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs
- (list python-coverage python-pytest))
+ (list python-coverage python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-editdistance))
(home-page "https://github.com/chriskuehl/identify")
@@ -28474,7 +28495,11 @@ effort to simplify the man pages with practical examples.")
;; This test fails. It tries to open a network socket.
(invoke "pytest" "-vv" "-k" "not test_smoke"))))))
(native-inputs
- (list python-coverage python-mock python-pytest))
+ (list python-coverage
+ python-mock
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://ekalinin.github.io/nodeenv/")
(synopsis "Create isolated node.js environments")
(description
@@ -28582,7 +28607,7 @@ Let's Encrypt.")
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/asottile/cfgv")
(synopsis "Configuration validation library")
(description
@@ -28821,7 +28846,8 @@ codecs for use in data storage and communication applications.")
python-pytest-doctestplus
python-pytest-timeout
python-pytest-xdist
- python-setuptools-scm))
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/zarr-developers/zarr-python")
(synopsis "Chunked, compressed, N-dimensional arrays for Python")
(description
@@ -29255,7 +29281,7 @@ they use the same path.")
(build-system pyproject-build-system)
(propagated-inputs
(list python-locket python-numpy python-pandas python-pyzmq python-toolz))
- (native-inputs (list python-setuptools))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/dask/partd/")
(synopsis "Appendable key-value storage")
(description "Partd stores key-value pairs. Values are raw bytes. We
@@ -29405,7 +29431,8 @@ parentdir_prefix = dask-
python-pytest-rerunfailures
python-pytest-runner
python-pytest-xdist
- python-versioneer))
+ python-versioneer
+ python-wheel))
(home-page "https://github.com/dask/dask/")
(synopsis "Parallel computing with task scheduling")
(description
@@ -29981,7 +30008,7 @@ the Trio framework}.")
"006vpl19bffy9fn0sssxbfakcvgrx7fhvy6l515fzln7vwpqf7zf"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-freezegun python-pytest))
+ (list python-freezegun python-pytest python-setuptools python-wheel))
(home-page "https://github.com/jmoiron/humanize")
(synopsis "Print numerical information in a human-readable form")
(description "This package provides a Python module that displays numbers
@@ -30535,7 +30562,11 @@ information in various formats.")
(list python-cairocffi python-cssselect2 python-defusedxml
python-pillow python-tinycss2))
(native-inputs
- (list python-pytest-flake8 python-pytest-isort python-pytest-runner))
+ (list python-pytest-flake8
+ python-pytest-isort
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://cairosvg.org/")
(synopsis "SVG to PDF/PS/PNG converter based on Cairo")
(description "CairoSVG is a SVG converter based on Cairo. It can export
@@ -32652,7 +32683,9 @@ and not test_transcript")))
python-pytest
python-pytest-cov
python-pytest-mock
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/python-cmd2/cmd2")
(synopsis "Tool for building interactive command line applications")
(description
@@ -35474,7 +35507,7 @@ functions defined in POSIX.1-2001 and POSIX.1-2008.")
"python-pyan3-fix-absolute-path-bug.patch"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-pytest-cov python-wheel))
+ (list python-pytest python-pytest-cov python-setuptools python-wheel))
(propagated-inputs
(list python-jinja2))
(home-page "https://github.com/Technologicat/pyan")
@@ -37025,7 +37058,13 @@ writing STL files. It supports both the text and binary forms of STL.")
"0hzshd665rl1bkwvaj9va4j3gs8nmb478fbvligx20663xhmzfzp"))))
(build-system python-build-system)
(propagated-inputs (list python-six))
- (native-inputs (list python-pyyaml python-mock python-pytest-cov))
+ (native-inputs
+ (list python-mock
+ python-pytest
+ python-pytest-cov
+ python-pyyaml
+ python-setuptools
+ python-wheel))
(arguments
`(#:phases (modify-phases %standard-phases
;; There is a bug in the test_suit specification.
@@ -37113,6 +37152,7 @@ adapted from the @code{packaging} package.")
python-pytest
python-pytest-cov
python-pytest-timeout
+ python-setuptools
python-setuptools-scm
python-wheel))
(home-page "https://github.com/iterative/shtab")
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 379516d2ff..1fca88ddb1 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -569,7 +569,7 @@ some support for generating and analysing traffic scenarios..")
(inputs
(list openmpi python-numpy))
(native-inputs
- (list python-pytest-cov))
+ (list python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-mpi4py))
(arguments
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 95015c30df..b2d363fe7a 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1173,9 +1173,11 @@ enabled web server.")
(native-inputs
(list python-nptyping
python-pytest
+ python-setuptools
python-setuptools-scm
python-sphobjinv
- python-typing-extensions))
+ python-typing-extensions
+ python-wheel))
(home-page "https://pypi.org/project/sphinx-autodoc-typehints/")
(synopsis "Type hints for the Sphinx autodoc extension")
(description "This extension allows you to use Python 3 annotations for
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 45a02ebbe2..b1b7e7d594 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -527,7 +527,9 @@ a simple interface that makes it easy to organize and browse feeds.")
python-mock
python-pylint
python-pytest
- python-vcrpy))
+ python-setuptools
+ python-vcrpy
+ python-wheel))
(home-page "https://gitlab.com/ajak/tuir")
(synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
(description
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 1254d48741..fb318654f6 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1205,8 +1205,14 @@ per-line fullscreen terminal rendering, and keyboard input event reporting.")
(build-system pyproject-build-system)
(propagated-inputs (list python-colorama python-log-symbols python-six
python-spinners python-termcolor))
- (native-inputs (list python-coverage python-nose python-pylint python-tox
- python-twine))
+ (native-inputs
+ (list python-coverage
+ python-nose
+ python-pylint
+ python-setuptools
+ python-tox
+ python-twine
+ python-wheel))
(home-page "https://github.com/manrajgrover/halo")
(synopsis "Python library to display graphical spinners in the terminal")
(description "Halo is a Python library to display graphical spinners in
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index e2debd0232..f1aeae7340 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -257,7 +257,11 @@ Pendulum instances.")
;; XXX: Fails to get timezone from /etc/localtime.
"--ignore=dateutil/test/test_tz.py")))
(native-inputs
- (list python-pytest python-pytest-cov python-setuptools-scm))
+ (list python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-six))
(home-page "https://dateutil.readthedocs.io/en/stable/")
@@ -513,13 +517,14 @@ timestamps.")
;; Remove when python-dateutil > 2.8.1.
"-k" "not test_parse_tz_name_zzz")))
(native-inputs
- (list ;; For testing
- python-chai
+ (list python-chai
python-pytest
python-pytest-cov
python-pytest-mock
python-pytz
- python-simplejson))
+ python-setuptools
+ python-simplejson
+ python-wheel))
(propagated-inputs
(list python-dateutil))
(home-page "https://github.com/arrow-py/arrow")
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3339e79390..bd831bdb35 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2315,14 +2315,16 @@ visualize your public Git repositories on a web interface.")
" and not test_healthy_venv_creator"
" and not test_r_hook and not test_r_inline"))))))))
(native-inputs
- `(("git" ,git-minimal/pinned)
- ("python-covdefaults" ,python-covdefaults)
- ("python-coverage" ,python-coverage)
- ("python-distlib" ,python-distlib)
- ("python-pytest" ,python-pytest)
- ("python-pytest-env" ,python-pytest-env)
- ("python-re-assert" ,python-re-assert)
- ("which" ,which)))
+ (list git-minimal
+ python-covdefaults
+ python-coverage
+ python-distlib
+ python-pytest
+ python-pytest-env
+ python-re-assert
+ python-setuptools
+ python-wheel
+ which))
;; Propagate because pre-commit is also used as a module.
(propagated-inputs
(list python-cfgv
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index a7bb9af2b8..2d304930fb 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2099,10 +2099,12 @@ mainly implemented in user space.")
(format #t "test suite not run~%")))))))
(native-inputs
(list python-avocado-framework
- python-setuptools-scm
python-flake8
python-isort
- python-pylint))
+ python-pylint
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-pygments
python-urwid
@@ -2857,7 +2859,9 @@ use with virtualization provisioning tools")
(list python-black
python-mypy
python-pyhamcrest
- python-twine))
+ python-setuptools
+ python-twine
+ python-wheel))
(propagated-inputs
(list python-beautifultable
python-click
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 369374860a..f59c3dc7b2 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -111,6 +111,7 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
@@ -1760,7 +1761,12 @@ generate code for the @code{python-xcbffib} package.")
(source (package-source xcffibgen))
(build-system pyproject-build-system)
(native-inputs
- (list pkg-config which xcb-proto xcffibgen))
+ (list pkg-config
+ python-setuptools
+ python-wheel
+ which
+ xcb-proto
+ xcffibgen))
(inputs
(list libxcb))
(propagated-inputs