summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-12-24 11:24:14 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-12-24 11:29:32 +0100
commit369b119ccfd482b756b450e52ac89b53a28fa8fc (patch)
tree647560b251d38a2a817f78770f3b200c7bdfd2b8
parent8d32ea0d16f3c3d2ab3072e7865d2437523aefa3 (diff)
gnu: Add emacs-tp.
* gnu/packages/emacs-xyz.scm (emacs-tp): New variable. Change-Id: I05690a8acf541d2f9df59446d603956e69495683
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f704a40a471..e2b1c092816 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16847,6 +16847,29 @@ color-name strings (such as \"blue\") and hex RGB color strings (such as
multiple project types.")
(license license:gpl3+))))
+(define-public emacs-tp
+ (package
+ (name "emacs-tp")
+ (version "0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/tp.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14vdn5syv7jghxvqlih9gvh82755r5gd8yxskq8bv6wkm4b0y0cs"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/martianh/tp.el")
+ (synopsis "Utilities to create transient menus for POSTing to an API")
+ (description
+ "This package provides functions, classes and methods to make it easier
+to create transient menus that send complex POST, PUT, or PATCH requests to
+JSON APIs.")
+ (license license:gpl3+)))
+
+
(define-public emacs-ivy-taskrunner
(let ((commit "75d8d67cfe3c29663fe0f5508a887adf40ed5162")
(revision "1"))