summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-13 17:01:18 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-14 19:10:55 +0800
commitf650fa36eee32817509b4c1a306d8a00ec054e7a (patch)
tree611a75eab09b70e2a48056d404837a2e6ef7df33
parent1d178f3af8b3f27d54101bcc62dbe2380b53e759 (diff)
gnu: lxqt-policykit: Update to 2.1.0.
* gnu/packages/lxqt.scm (lxqt-policykit): Update to 2.1.0. [inputs]: Simplify. Replace polkit-qt with polkit-qt6. Change-Id: Ifc7caa4521b22b593ee8bb30d78fd88a3c3724d3
-rw-r--r--gnu/packages/lxqt.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index c6c06aa164..7535410c39 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -561,26 +561,19 @@ possible for applications to export and import their menus over DBus.")
(define-public lxqt-policykit
(package
(name "lxqt-policykit")
- (version "1.3.0")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "051lb4kx29rx3ls3whlrbi83r9z9pdiqwyb1wbni56aqilv0svh0"))))
+ (base32 "0h0hi7aimjhc6rn4w8wz3kmvpkx7g6bf9i1fclan7j7ic80cf160"))))
(build-system cmake-build-system)
(inputs
- (list kwindowsystem-5
- liblxqt
- libqtxdg
- pcre
- polkit-qt
- qtbase-5
- qtsvg-5
- qtx11extras))
+ (list liblxqt polkit polkit-qt6))
(native-inputs
- (list pkg-config polkit lxqt-build-tools qttools-5))
+ (list pkg-config lxqt-build-tools))
(arguments '(#:tests? #f)) ; no test target
(home-page "https://lxqt-project.org")
(synopsis "The LXQt PolicyKit agent")