summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-13 17:03:46 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-14 19:10:55 +0800
commitcd906703d0a1174c9ca9cef42503c14685a49379 (patch)
tree81e291ef0519c968646dfa89d449961157cd53c8
parent2390d1f314d69c34b95badbfbcdfe000bb5215a2 (diff)
gnu: lxqt-runner: Update to 2.1.1.
* gnu/packages/lxqt.scm (lxqt-runner): Update to 2.1.1. [inputs]: Add layer-shell-qt and menu-cache. Simplify. Change-Id: Idcd9496031e7fde7fbe2c13c09fd6cd9856cc91b
-rw-r--r--gnu/packages/lxqt.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index d424f2df13..6e7f8c7d70 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -645,27 +645,24 @@ Qt with LXQt.")
(define-public lxqt-runner
(package
(name "lxqt-runner")
- (version "1.3.0")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1916cl12v09x4iqrgvp2dwchy50wa97a0y68q4rdigarpdrp3x7j"))))
+ (base32 "0pmviizv7cxiqn2868bmbwgqrakmp4fv6a1wzbal0gndgc14yxmw"))))
(build-system cmake-build-system)
(inputs
- (list kwindowsystem-5
+ (list kwindowsystem
+ layer-shell-qt
liblxqt
- libqtxdg
lxqt-globalkeys
muparser
- pcre
- qtbase-5
- qtsvg-5
- qtx11extras))
+ menu-cache))
(native-inputs
- (list pkg-config qttools-5 lxqt-build-tools))
+ (list pkg-config lxqt-build-tools))
(arguments '(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")
(synopsis "Tool used to launch programs quickly by typing their names")