summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-13 16:46:47 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-14 19:10:55 +0800
commit0d285b290f9d5d029c2eeb57b1ab0bd6351ce830 (patch)
tree99a58ddb10ed838612c999b772d1e069ac5e7ed7
parent22ad1c1f0663b04cc45048fdd96b67309d3bf329 (diff)
gnu: Remove lxqt-connman-applet.
Archived in 2024.04, won't work with Qt6. * gnu/packages/lxqt.scm (lxqt-connman-applet): Remove variable. Change-Id: I5d3476b567dbb90c85b3b6faf0150018593d3751
-rw-r--r--gnu/packages/lxqt.scm46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 72a7832d84..75c275dd33 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1057,52 +1057,6 @@ easily publishing them on internet image hosting services.")
like @command{tar} and @command{zip}.")
(license license:gpl2+)))
-(define-public lxqt-connman-applet
- ;; since the main developers didn't release any version yet, their
- ;; latest commit on `master` branch at the moment used for this version.
- (let ((commit "db1618d58fd3439142c4e44b24cba0dbb68b7141")
- (revision "0"))
- (package
- (name "lxqt-connman-applet")
- (version (git-version "0.15.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/lxqt/" name))
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "087641idpg7n8yhh5biis4wv52ayw3rddirwqb34bf5fwj664pw9"))))
- (build-system cmake-build-system)
- (inputs
- (list kwindowsystem-5
- qtbase-5
- qtsvg-5
- liblxqt
- qtx11extras
- libqtxdg))
- (native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)
- ("qtlinguist" ,qttools-5)))
- (arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-definitions
- (lambda _
- (substitute* "CMakeLists.txt"
- (("include\\(LXQtCompilerSettings NO_POLICY_SCOPE\\)")
- "include(LXQtCompilerSettings NO_POLICY_SCOPE)
-remove_definitions(-DQT_NO_CAST_TO_ASCII -DQT_NO_CAST_FROM_ASCII)"))
- #t)))))
- (home-page "https://github.com/lxqt/lxqt-connman-applet")
- (synopsis "System-tray applet for connman")
- (description "This package provides a Qt-based system-tray applet for
-the network management tool Connman, originally developed for the LXQT
-desktop.")
- (license license:lgpl2.1+))))
-
;; The LXQt Desktop Environment
(define-public lxqt