summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-10-15 12:54:07 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-10-15 13:01:33 +0200
commitf443f5b0cd77cbbfa70cd915b4082ce32340127e (patch)
tree9cc5d98158b25d99007ad60b05b57c65de8da4d5
parentadaaa32658a395022c1b4fb9f3c61e6ed6c0f247 (diff)
gnu: Add perl-text-markdown.
* gnu/packages/markup.scm (perl-text-markdown): New variable. Change-Id: Ibeaa8d3959e4ddea15650c97f5ca598c3cc8c60a
-rw-r--r--gnu/packages/markup.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 2cc3d0415d..11682dd4a1 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -322,6 +323,31 @@ documents in the ms and man formats, LaTeX, gemini, and terminal output.")
(home-page "https://www.pell.portland.or.us/~orc/Code/discount/")
(license license:bsd-3)))
+(define-public perl-text-markdown
+ (package
+ (name "perl-text-markdown")
+ (version "1.000031")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BO/BOBTFISH/Text-Markdown-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "06y79lla8adkqhrs41xdddqjs81dcrh266b50mfbg37bxkawd4f1"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-list-moreutils
+ perl-module-install
+ perl-test-differences
+ perl-test-exception))
+ (home-page "https://metacpan.org/release/Text-Markdown")
+ (synopsis "Convert Markdown syntax to (X)HTML")
+ (description "@code{Text::Markdown} is a Perl module that provides an
+alternate implementation of the Markdown implementation by John Gruber (see
+the markdown package). It is a slower implementation, but better
+maintained.")
+ (license license:bsd-3)))
+
(define-public perl-text-markdown-discount
(package
(name "perl-text-markdown-discount")