summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:00 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:12:30 +0100
commited6b9449a13097280f41089b57bbd315a74c5ea8 (patch)
tree105be947c15b520f6ff0e32bd54ecba9868cddff
parent57c38bb103a65c230e63f927191da358a67d1db9 (diff)
gnu: Add perl-dbix-class-timestamp.
* gnu/packages/databases.scm (perl-dbix-class-timestamp): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/databases.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 14d1d7f8c7..7d564f5faf 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2398,6 +2398,37 @@ Ipdate or create actions will set the specified columns to the value returned
by the callback you specified as a method name or code reference.")
(license license:perl-license)))
+(define-public perl-dbix-class-timestamp
+ (package
+ (name "perl-dbix-class-timestamp")
+ (version "0.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RI/RIBASUSHI/DBIx-Class-TimeStamp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1zhr4r5ffihqsh2imap7zmps2y0h71piqqhg2nqhcwkjhvlxb958"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-class-accessor-grouped
+ perl-datetime-format-mysql
+ perl-datetime-format-sqlite
+ perl-dbd-sqlite
+ perl-module-install
+ perl-test-pod
+ perl-time-warp))
+ (propagated-inputs (list perl-datetime
+ perl-dbix-class
+ perl-dbix-class-dynamicdefault))
+ (home-page "https://metacpan.org/release/DBIx-Class-TimeStamp")
+ (synopsis
+ "DBIx::Class extension to update and create date and time based fields")
+ (description
+ "This package works in conjunction with @code{InflateColumn::DateTime} to
+automatically set update and create date and time based fields in a table.")
+ (license license:perl-license)))
+
(define-public perl-dbd-pg
(package
(name "perl-dbd-pg")