summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Simon <alexis.simon@runbox.com>2025-01-14 17:13:01 +0100
committerjgart <jgart@dismail.de>2025-01-14 21:12:11 -0600
commita51fc0d828e156551758220e44b060426fb4314c (patch)
tree0153fc3c71f7a5c269684370ffcf4e5b006dff58
parentfac97d2a7f6f041ab1abb0692e891db3cf9dba74 (diff)
gnu: python-cyvcf2: Update to 0.31.1
This commit also fixes the previous build failure. * gnu/packages/bioinformatics.scm (python-cyvcf2): Update to 0.31.1. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Icc5057cf9f5e6ba141e6e29e8f4db657cd04c1d2 Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 34a39a48f1..1bf0b4b09a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2357,7 +2357,7 @@ and sequence consensus.")
(define-public python-cyvcf2
(package
(name "python-cyvcf2")
- (version "0.30.28")
+ (version "0.31.1")
(source
(origin
(method git-fetch)
@@ -2366,7 +2366,7 @@ and sequence consensus.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "16yhfax509zyip8kkq2b0lflx5bdq5why7d785ayrqyzzq2rxqkk"))
+ (base32 "02x7ic2q4x3sfwx9n2sxg0a79iifjal0a68fqp9ljsfvdx4b7nq5"))
(modules '((guix build utils)))
(snippet
;; Delete bundled library
@@ -2395,7 +2395,11 @@ and sequence consensus.")
(setenv "CYTHONIZE" "1")
(setenv "CYVCF2_HTSLIB_MODE" "EXTERNAL"))))))
(inputs (list curl htslib libdeflate openssl zlib))
- (native-inputs (list python-cython python-pytest))
+ (native-inputs
+ (list python-cython
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-click
python-coloredlogs