summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-13 17:10:32 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-14 19:10:55 +0800
commit89412996cc23a2c14ec4696b071884dde83452c3 (patch)
tree96f4f2fa0f41741595bf1aaeab7d341783038ec8
parentde6d833937ff1bce03cf70d9bdb09fc96b659e0c (diff)
gnu: qterminal: Update to 2.1.0.
* gnu/packages/lxqt.scm (qterminal): Update to 2.1.0. [inputs]: Add layer-shell-qt. Replace qtbase-5 with qtbase. Remove qtx11extras. [native-inputs]: Remove qttools-5. Change-Id: Ifb873569493a0e62b51ad5ef97cbe8369ff35977
-rw-r--r--gnu/packages/lxqt.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index b77e02dde6..c963bb1ae8 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -972,19 +972,19 @@ processes currently in existence, much like code{top} or code{ps}.")
(define-public qterminal
(package
(name "qterminal")
- (version "1.3.0")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1ibhl51mggf81xhvcmrkbsxl7ls8v0sn74rwhjxw4vqk6r6fhiby"))))
+ (base32 "0g11n43msp0dwl68nf5wdh6kwi48xqc43pl9bpg4wsdw8n37hpm6"))))
(build-system cmake-build-system)
(inputs
- (list qtbase-5 qtx11extras qtermwidget))
+ (list layer-shell-qt qtbase qtermwidget))
(native-inputs
- (list lxqt-build-tools qttools-5))
+ (list lxqt-build-tools))
(arguments
'(#:tests? #f)) ; no tests
(home-page "https://lxqt-project.org")