summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2025-01-02 21:14:21 +0000
committerLudovic Courtès <ludo@gnu.org>2025-01-06 16:25:38 +0100
commit84a68cffe6abf1056df2607e79ef587b63820a6e (patch)
tree820a952ce2d67423d80229159ff1332b46850c54
parente2d0eba13cdb1de2d7209da0e70f149ff166eb0f (diff)
gnu: Add julia-hostcpufeatures.
* gnu/packages/julia-xyz.scm (julia-hostcpufeatures): New variable. Change-Id: I47ccade771b0316eb46c88aaa912dbc699eed453 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a6a4eabd6f9..6cae46dc2b6 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2943,6 +2943,28 @@ operations in Julia.")
library for parsing HTML.")
(license license:expat)))
+(define-public julia-hostcpufeatures
+ (package
+ (name "julia-hostcpufeatures")
+ (version "0.1.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaSIMD/HostCPUFeatures.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p0phms2zbmlv8bn20lnwn1jh0xjvz7vq266zf296adha534q9pq"))))
+ (build-system julia-build-system)
+ (propagated-inputs (list julia-bittwiddlingconveniencefunctions
+ julia-ifelse julia-static))
+ (home-page "https://github.com/JuliaSIMD/HostCPUFeatures.jl")
+ (synopsis "Provides information about the CPU's features")
+ (description "This package provides information about the features of
+the host CPU in Julia.")
+ (license license:expat)))
+
(define-public julia-http
(package
(name "julia-http")