summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-12-07 16:56:11 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-12-08 11:32:57 -0500
commit731fa9f96ab95304ce8469b03bd17ac73e24d02a (patch)
tree9553cd12717a8ab2ccdfb193559a0f1c2457464a
parente46bc3d928282c74a7b2d9af6af81972002f0a17 (diff)
gnu: python-gphoto2: Update to 2.5.0.
* gnu/packages/python-xyz.scm (python-gphoto2): Update to 2.5.0. [license]: Change to lgpl3+ (upstream changed in version 2.4.0). Change-Id: Ib15737ded100458c955652ee2c075a12016d0689
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 78ca85a29f8..a98fdf31815 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2341,13 +2341,13 @@ allows one to read and write JPEG 2000 files")
(define-public python-gphoto2
(package
(name "python-gphoto2")
- (version "2.2.1")
+ (version "2.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gphoto2" version))
(sha256
(base32
- "118zm25c8mlajfl0pzssnwz4b8lamj9dgymla9rn4nla7l244a0r"))))
+ "104yb4g427rqjkaw3i0w30x3sssvmpna802nabjclzq688y7ml4p"))))
(build-system python-build-system)
(native-inputs
(list pkg-config))
@@ -2358,7 +2358,7 @@ allows one to read and write JPEG 2000 files")
(description "@code{python-gphoto2} is a comprehensive Python interface
(or binding) to @code{libgphoto2}. It is built using @code{SWIG} to
automatically generate the interface code.")
- (license license:gpl3+)))
+ (license license:lgpl3+)))
(define-public python-colour
(package