summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2025-01-15 21:48:19 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-15 22:03:00 +0100
commit72bbab16f2b6f90f7cbe08bd14830d31136b8c9a (patch)
tree9c7e1a744786c342ae1ddff33c7a76e896557da9
parentc5d1de30284859e8aff3dc29eb6a54f1d5cdf3b4 (diff)
gnu: emacs-xenops: Update to 0.0.1.
* gnu/packages/emacs-xyz.scm (emacs-xenops): Update to 0.0.1. Change-Id: I9ee91d166b6414e53686a4627f5c5d77debe3987
-rw-r--r--gnu/packages/emacs-xyz.scm54
1 files changed, 25 insertions, 29 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 223eacfd6a..ce131bf7fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4933,37 +4933,33 @@ as brings user experience improvements.")
(license license:gpl3+))))
(define-public emacs-xenops
- (let ((revision "0")
- (commit "6d9a8d654a6102484ac9087f25931f0664e7dd07"))
- (package
- (name "emacs-xenops")
- (version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dandavison/xenops.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1sasm6rrhvsqndcwm74cgmlk96g2wx81fk9z32rq095yvim4y5qq"))))
- (propagated-inputs (list emacs-aio emacs-auctex emacs-avy emacs-dash
- emacs-f emacs-s))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _
- (setenv "HOME" "/tmp")
- (chdir "lisp"))))))
- (synopsis "WYSIWYG LaTeX environment")
- (description "This package provides a WYSIWYG LaTeX environment.
+ (package
+ (name "emacs-xenops")
+ (version "0.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dandavison/xenops/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gaym5bl6fhdp4pa283qcx5qf77wz2g7xl9n1gyvvl9yl0kvrb48"))))
+ (propagated-inputs (list emacs-aio emacs-auctex emacs-avy emacs-dash
+ emacs-f emacs-s))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (chdir "lisp"))))))
+ (synopsis "WYSIWYG LaTeX environment")
+ (description "This package provides a WYSIWYG LaTeX environment.
It uses @command{dvisvgm}, @command{xclip}, @command{pngpaste} and
@command{latex}.")
- (home-page "https://github.com/dandavison/xenops")
- (license license:expat))))
+ (home-page "https://github.com/dandavison/xenops")
+ (license license:expat)))
(define-public emacs-autothemer
(let ((commit "8f72afc6dba5ad7cc3a201a084fd20571f945d2e")) ;version bump