summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-21 14:48:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:38 +0200
commit71ae154d9bfb9b7798a40e1bd17a0d59200e2776 (patch)
tree7c966b5cbddbf4068a854ffbe8fd703aa8f2c223
parentc22e114471ae5c6c24790f67c1aa58f439fb522f (diff)
gnu: xremap-hyprland: Undeprecate the package.
* gnu/packages/rust-apps.scm (xremap-hyprland): Inherit from rust-xremap. Change-Id: I54494fe66fe248181b44d3538c78311e5e7cde58
-rw-r--r--gnu/packages/rust-apps.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 6d1d3e709f..62668dfc2a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3785,7 +3785,12 @@ advanced keybindings, word-level diff highlighting, syntax highlighting for
((#:features _) '(list "wlroots"))))))
(define-public xremap-hyprland
- (deprecated-package "xremap-hyprland" xremap-wlroots))
+ (package
+ (inherit rust-xremap)
+ (name "xremap-hyprland")
+ (arguments
+ (substitute-keyword-arguments (package-arguments rust-xremap)
+ ((#:features _) '(list "hyprland"))))))
(define-public xremap-sway
(deprecated-package "xremap-sway" xremap-wlroots))