summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:48:57 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:37 +0300
commit703951b157db1c413f8718644d3c1e20f5ec5e1b (patch)
tree3d9037ef23558c87084f8e8d8d7e704e1ad358d8
parent215ae40b5d953a98b4c71f772c515adf5ad8ddf5 (diff)
gnu: Add go-github-com-makenowjust-heredoc.
* gnu/packages/golang-xyz.scm (go-github-com-makenowjust-heredoc): New variable. Change-Id: I686dfd6a798da764b004a53a562ca788e70f8cd5 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 913b741871..c3342c91b0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4916,6 +4916,30 @@ Printf/Sprintf etc.")
(native-inputs
(list go-github-com-stretchr-testify))))
+(define-public go-github-com-makenowjust-heredoc
+ (package
+ (name "go-github-com-makenowjust-heredoc")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/makenowjust/heredoc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18f21zm8n2wlnkz1ylw8rcxmqxyv2rlz8749yfqggm2m0m2884pj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/MakeNowJust/heredoc"))
+ (home-page "https://github.com/MakeNowJust/heredoc")
+ (synopsis "Here-documents with indent")
+ (description
+ "This package implements a functionality of creating here-documents from
+raw strings.")
+ (license license:expat)))
+
(define-public go-github-com-marcinbor85-gohex
;; No release, see <https://github.com/marcinbor85/gohex/issues/5>.
(let ((commit "baab2527a9a2a4abb3dc06baabedfa5e0268b8d8")