summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-29 11:47:10 +0100
committerLudovic Courtès <ludo@gnu.org>2025-01-14 14:11:42 +0100
commit64d95c78e32b53319e78e846b18b74206418b956 (patch)
tree474d6afdd26f5b8a5731c7f4c60af62eb9552a42
parentf4abe0fc613009b29c5f1e50f74c75785ecbf0cf (diff)
gnu: gnupg: Update to 2.4.7.
* gnu/packages/gnupg.scm (gnupg): Update to 2.4.7. [arguments]: Adjust ‘patch-test-paths’. Change-Id: I63fabffebf80a2c9f1bb9ba421712bb49100711e
-rw-r--r--gnu/packages/gnupg.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 74bd698a7a..73d507f3dd 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -320,9 +320,10 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- ;; Note: The 2.2.X releases are Long Term Support (LTS), so stick to it
- ;; for our stable 'gnupg'.
- (version "2.2.39")
+ ;; Note: Odd minor versions are usually for development purposes. See
+ ;; <https://gnupg.org/download/index.html> for how to pick the right
+ ;; version.
+ (version "2.4.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
@@ -330,7 +331,7 @@ compatible to GNU Pth.")
(patches (search-patches "gnupg-default-pinentry.patch"))
(sha256
(base32
- "0bscgv9gg9yhlpyia7b9l438cq6dvv6pwlhbl70df9phhmkdnx5b"))))
+ "0ipbhlxwr79l66b907640a0j67s04w826s50djqf7q579mp7093v"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -391,9 +392,7 @@ compatible to GNU Pth.")
(string-append (getcwd) "/tests/gpgscm/gpgscm")))))
(add-before 'build 'patch-test-paths
(lambda _
- (substitute* '("tests/inittests"
- "tests/pkits/inittests"
- "tests/Makefile"
+ (substitute* '("tests/pkits/inittests"
"tests/pkits/common.sh"
"tests/pkits/Makefile")
(("/bin/pwd") (which "pwd")))