summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Riße <matrss@0px.xyz>2024-11-30 10:10:46 +0100
committerLars-Dominik Braun <lars@6xq.net>2024-11-30 13:53:12 +0100
commit5fd105bf285250af02670b0a9a4615e2b458861d (patch)
treee150ee615e324d5e47b2222145204c409f6f8311
parent0fe87722697fd83527e1e8c134d13ac8e44246fb (diff)
gnu: Add ghc-servant-client-core.
* gnu/packages/haskell-xyz.scm (ghc-servant-client-core): New variable. Change-Id: I26373f05da6fdba95b7791959e18e6577c3f5f37 Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
-rw-r--r--gnu/packages/haskell-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 30a674b080..afbedcba78 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16683,6 +16683,41 @@ serving them . You can learn about the basics in the
CHANGELOG>")
(license license:bsd-3)))
+(define-public ghc-servant-client-core
+ (package
+ (name "ghc-servant-client-core")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "servant-client-core" version))
+ (sha256
+ (base32 "0cisc5cyl367cwrch1gr812aspd36a21hkwi6mwj708rpspwvrmc"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "servant-client-core")))
+ (inputs (list ghc-constraints
+ ghc-servant
+ ghc-aeson
+ ghc-base-compat
+ ghc-base64-bytestring
+ ghc-free
+ ghc-http-media
+ ghc-http-types
+ ghc-network-uri
+ ghc-safe
+ ghc-sop-core))
+ (native-inputs (list ghc-hspec ghc-hspec-discover ghc-quickcheck))
+ (arguments
+ `(#:cabal-revision ("5"
+ "147ws71hwp8zck7ph8kcyh18524s8g0b7qvxjsvsm1yvw77c60gh")))
+ (home-page "http://docs.servant.dev/")
+ (synopsis
+ "Core functionality and class for client function generation for servant APIs")
+ (description
+ "This library provides backend-agnostic generation of client functions. For more
+information, see the README.")
+ (license license:bsd-3)))
+
(define-public ghc-servant-server
(package
(name "ghc-servant-server")