summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-09-16 17:29:09 +0200
committerLudovic Courtès <ludo@gnu.org>2024-11-17 23:15:50 +0100
commit5e12096e90a1836fdfaaada8b42e52b5d7efa3ec (patch)
tree018a09fe1987d9663dabd45219f0be457045a6f3
parent677b16322a950384429cf0d732cd8ddb601cde7b (diff)
gnu: coq-mathcomp-bigenough: Use new style.
* gnu/packages/coq.scm (coq-mathcomp-bigenough) [arguments]: Use new style and remove uneeded make flags. Change-Id: I11a6350a10cedd682cf598ecb8660b63a12aa00d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/coq.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 31d1e8d51d7..166657fdd1f 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -753,21 +753,16 @@ subsume notations for finite sets.")
"02f4dv4rz72liciwxb2k7acwx6lgqz4381mqyq5854p3nbyn06aw"))))
(build-system gnu-build-system)
(arguments
- `(;; No references to tests in Makefile.common.
- ;; It doesn't appear as though tests will be included
- ;; by the packaged project in the future.
- #:tests? #f
- #:make-flags ,#~(list (string-append "COQBIN="
- #$(this-package-input "coq")
- "/bin/")
- (string-append "COQMF_COQLIB="
- (assoc-ref %outputs "out")
- "/lib/ocaml/site-lib/coq")
- (string-append "COQLIBINSTALL="
- (assoc-ref %outputs "out")
- "/lib/coq/user-contrib"))
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
+ (list ;; No references to tests in Makefile.common.
+ ;; It doesn't appear as though tests will be included
+ ;; by the packaged project in the future.
+ #:tests? #f
+ #:make-flags
+ #~(list (string-append "COQLIBINSTALL=" #$output
+ "/lib/coq/user-contrib"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(propagated-inputs (list coq coq-mathcomp which))
(home-page "https://math-comp.github.io/")
(synopsis "Small library to do epsilon - N reasoning")