summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 23:02:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:54 +0000
commit53a176434d8a10660c3be848b4d17527f5d32cf5 (patch)
treec368179aa465d8cb8d878d723e00c27a18f60a2a
parentdb2ccd2479317fc4870e67b8e2c2192361ee08f5 (diff)
gnu: Add go-github-com-rogpeppe-fastuuid.
* gnu/packages/golang-xyz.scm (go-github-com-rogpeppe-fastuuid): New variable. Change-Id: Ie8458f79e0b39e8660a2fdd64bb4d4482cd22339
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4269bcdac5..832e56b042 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6362,6 +6362,31 @@ routines querying a database but without sending too much queries in order to
not overload the given database.")
(license license:expat)))
+(define-public go-github-com-rogpeppe-fastuuid
+ (package
+ (name "go-github-com-rogpeppe-fastuuid")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rogpeppe/fastuuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "028acdg63zkxpjz3l639nlhki2l0canr2v5jglrmwa1wpjqcfff8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/rogpeppe/fastuuid"))
+ (home-page "https://github.com/rogpeppe/fastuuid")
+ (synopsis "192-bit UUID generator in Golang")
+ (description
+ "Package fastuuid provides UUID generation of 192 bit universally unique
+identifiers. It also provides simple support for 128-bit RFC-4122 V4 UUID
+strings.")
+ (license license:bsd-3)))
+
(define-public go-github-com-rogpeppe-go-internal
(package
(name "go-github-com-rogpeppe-go-internal")