summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-21 15:29:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:39 +0200
commit534040b2b772205be99fe5e8121bab6e6909161b (patch)
tree632276dad690a33de351f3e37261b29de40fcee9
parent2bf08870b907f22496658f63413bb9c9d0076303 (diff)
gnu: rust-bindgen-cli: Update to 0.70.1.
* gnu/packages/rust-apps.scm (rust-bindgen-cli): Update to 0.70.1. [cargo-inputs]: Replace rust-bindgen-0.69 with 0.70. [arguments]: Adjust the install path for the bash completions. Change-Id: I67fa0f1795f98aeba1736f46df1a58a565f27184
-rw-r--r--gnu/packages/rust-apps.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 7845744387..652793755b 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2432,18 +2432,18 @@ rebase.")
(define-public rust-bindgen-cli
(package
(name "rust-bindgen-cli")
- (version "0.69.5")
+ (version "0.70.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "bindgen-cli" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1g984q5f5j6bglmbz4hbw40srhb5jywjhwc2v2livcxhvdq2hw8m"))))
+ (base32 "1anm1gci1ycbv6sz4a5dan7phqbypcnw48xribxmm1wdsm39wgrk"))))
(build-system cargo-build-system)
(arguments
`(#:install-source? #f
- #:cargo-inputs (("rust-bindgen" ,rust-bindgen-0.69)
+ #:cargo-inputs (("rust-bindgen" ,rust-bindgen-0.70)
("rust-clap" ,rust-clap-4)
("rust-clap-complete" ,rust-clap-complete-4)
("rust-env-logger" ,rust-env-logger-0.10)
@@ -2465,9 +2465,9 @@ rebase.")
(let* ((out (assoc-ref outputs "out"))
(share (string-append out "/share"))
(bindgen (string-append out "/bin/bindgen")))
- (mkdir-p (string-append share "/bash-completion/completions"))
+ (mkdir-p (string-append out "/etc/bash_completion.d/"))
(with-output-to-file
- (string-append share "/bash-completion/completions/bindgen")
+ (string-append out "/etc/bash_completion.d/bindgen")
(lambda _ (invoke bindgen "--generate-shell-completions" "bash")))
(mkdir-p (string-append share "/fish/vendor_completions.d"))
(with-output-to-file