summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2024-11-09 20:08:25 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-12 17:41:38 +0900
commit4bfe5fc5846fadf505e08b1df4f5d27f63ce08c9 (patch)
tree1f6ecb3e4f13c169fef4ce4d0b271f0eb76932d2
parent66b1471199cc077feb39ae58d5365e03f71f8fdb (diff)
gnu: yosys: Update to 0.46.
* gnu/packages/fpga.scm (yosys): Update to 0.46. Change-Id: Id980679e6576b27429611f8399eff2185e57d684 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/fpga.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index ecf111f8be..6064b2019b 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -147,15 +149,15 @@ For synthesis, the compiler generates netlists in the desired format.")
(define-public yosys
(package
(name "yosys")
- (version "0.26")
+ (version "0.46")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/YosysHQ/yosys")
- (commit (string-append "yosys-" version))))
+ (commit version)))
(sha256
(base32
- "0s79ljgbcfkm7l9km7dcvlz4mnx38nbyxppscvh5il5lw07n45gx"))
+ "1zj7vbpy6v1wn4p5cjs4hdjd467a1j1aj2qhs148bl2s6mzq3p86"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -214,6 +216,7 @@ For synthesis, the compiler generates netlists in the desired format.")
tcl)) ; tclsh for the tests
(inputs
(list abc
+ bash-minimal
graphviz
gtkwave
libffi