summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-14 20:25:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:53 +0100
commit4bb0b5be20074c53929c175f3fba3a9b56b7e1f6 (patch)
tree74d8451488349dfb5a01833c78466f3835c9cb15
parent9abc2e2d4fc581797a26bb3a3ef0f0297f699e87 (diff)
gnu: go-github-com-google-go-github: Adjust inputs.
* gnu/packages/golang-web.scm (go-github-com-google-go-github): Swap native-inputs to propagated-inputs. [propagated-inputs]: Add go-golang-org-x-oauth2, and go-golang-org-x-sync. Change-Id: I3be1b7c0b576e9c6bf5c1efb3904321b6f9d0e7f
-rw-r--r--gnu/packages/golang-web.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0fb966ed79..b204280317 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1072,8 +1072,11 @@ processes.")
`(#:tests? #f ;application/octet-stream instead of text/plain
#:import-path "github.com/google/go-github/v26/github"
#:unpack-path "github.com/google/go-github/v26"))
- (native-inputs
- (list go-github-com-google-go-querystring go-golang-org-x-crypto))
+ (propagated-inputs
+ (list go-github-com-google-go-querystring
+ go-golang-org-x-crypto
+ go-golang-org-x-oauth2
+ go-golang-org-x-sync))
(home-page "https://github.com/google/go-github/")
(synopsis "Client library for accessing the GitHub API v3")
(description "@code{go-github} is a Go client library for accessing the