summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 10:19:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 10:24:39 +0100
commit3581d9d3bdf741f9231a415d8b22cf42d9ba9f13 (patch)
tree7c063db7243eb30a17a74d56893dd58ebe1bcc43
parentc5b399c71861b54a1b7a18d6f9aa33c12b3754e6 (diff)
gnu: python-tldr: Swap to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-tldr) [build-system]: Swap to pyproject-build-system. [arguments]: Adjust indentation. <#:test-flags>: Move test exclusion here. <#:phases>: Use standard 'check phase. Change-Id: Ie87b5810027998bf33325c04021dbeb7cb24e6e2
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 96221bde33..22351e813a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27698,18 +27698,16 @@ Public Suffix List's private domains as well.")
(file-name (git-file-name name version))
(sha256
(base32 "15mab6a7ph2rviy5f2ypid6qdbb583fvaf5zhd6q0nrggxx0kkcm"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'build 'build-doc
- (lambda _
- (invoke "make" "-C" "docs")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; This test fails. It tries to open a network socket.
- (invoke "pytest" "-vv" "-k" "not test_error_message")))))))
+ (list
+ ;; This test fails. It tries to open a network socket.
+ #:test-flags #~(list "-k" "not test_error_message")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'build-doc
+ (lambda _
+ (invoke "make" "-C" "docs"))))))
(native-inputs
(list python-pytest
python-pytest-runner