summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-17 21:42:01 +0000
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:38:03 +0100
commit230740b032d9f243185ff87e43aa5b6976e6a205 (patch)
treec329d42e1f0048767fd27c03a360157fcb05fce6
parent51d8ae3af6aa727657dd1ff48237c1354289aac6 (diff)
gnu: python-miio: Migrate to pyproject-build-system.
* gnu/packages/android.scm (python-miio) [build-system]: Swap to pyproject-build-system. [arguments] <phases>: Remove 'relax-requirements. Use default 'check. [native-inputs]: Remove python-sphinx; add python-poetry-core. Change-Id: I0749f313d23e55bac0174a9ccd38aa92ac6eb26d
-rw-r--r--gnu/packages/android.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index c3101bcc86f..9c71a4ee475 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1105,23 +1105,11 @@ useful for reverse engineering, analysis of Android applications and more.")
(sha256
(base32
"05kc0icap3a4iw4910zfqi61zphcf6x958v2b5x68fy51ld3b704"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.py"
- (("cryptography>=35")
- "cryptography"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "miio")))))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest
+ (list python-poetry-core
+ python-pytest
python-pytest-mock
- python-sphinx
python-sphinx-click
python-sphinx-rtd-theme
python-sphinxcontrib-apidoc))