summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 16:06:37 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:44 +0000
commit20a8dac0b56ffa4f349a1d23a36b96ffb81a1f7d (patch)
treee0cfb352877d33dde4585b00429b66275b691bac
parent0cd1b7d3dd62eb365ad5ee209e12a6e5344b36c8 (diff)
gnu: python-astrodendro: Update to 0.3.1.
* gnu/packages/astronomy.scm (python-astrodendro): Update to 0.3.1. [source]: Swap to PyPI tarball containing a fresh release. [phases]: Remove 'set-env-version, no longer required. Change-Id: I3180990d8a12747b7b301680a705f956a7f47e0c
-rw-r--r--gnu/packages/astronomy.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 680dd8c673..9750cc6563 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1756,32 +1756,16 @@ astronomical images, especially when there is no WCS information available.")
(license license:expat)))
(define-public python-astrodendro
- ;; XXX: 0.2.0 was released 8 years ago and not compatible with Python 3.10,
- ;; use the latest commit on master branch, see
- ;; <https://github.com/dendrograms/astrodendro/issues/189>.
- (let ((commit "3181c36489caa4c62b36b7ec8e06f4da65af6fda")
- (revision "0"))
(package
(name "python-astrodendro")
- (version (git-version "0.2.0" revision commit))
+ (version "0.3.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dendrograms/astrodendro")
- (commit commit)))
+ (method url-fetch)
+ (uri (pypi-uri "astrodendro" version))
(sha256
- (base32 "1imahzl0g8r1lxyiz9wi9q4zk519yxgn6qs1nb0ybb34sipjs4kz"))
- (file-name (git-file-name name version))))
+ (base32 "0pav2rq5q0wyr38g6z8ai4z2iqqc9x04iwll158yvkvgnv352m0i"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'build 'set-env-version
- (lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
- #$(version-major+minor+point version)))))))
(native-inputs
(list python-pytest
python-setuptools
@@ -1797,7 +1781,7 @@ astronomical images, especially when there is no WCS information available.")
(description
"This package provides an way to compute dendrograms of observed or
simulated Astronomical data in Python.")
- (license license:expat))))
+ (license license:expat)))
(define-public python-astroml
(package