summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-16 09:44:50 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:42 +0000
commit1ef178c644178304b24bd29c7563ab0529c15f8f (patch)
treefa8dd0c4c39f8108d96db6c80636c92ab5bac3d6
parente6dd1f411d16f34be0f32a854573c32324b724ff (diff)
doc: Document new options for pyproject-build-system.
* doc/guix.texi (Build Systems): Add documentation for changed #:configure-flags and new #:backend-path. Change-Id: Ic8be598ea52ae04230b1e61c329ee55ccbb5dd63
-rw-r--r--doc/guix.texi12
1 files changed, 12 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index a2915de954..b37d8bae8e 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -9923,6 +9923,18 @@ The API is slightly different from @var{python-build-system}:
@item
@code{#:use-setuptools?} and @code{#:test-target} is removed.
@item
+@code{#:configure-flags} is changed. Instead of a list
+this option must be a JSON object, whose interpretation
+depends on the build backend. For instance the example from
+@url{https://peps.python.org/pep-0517/#config-settings,PEP 517}
+should be written as @code{'(@@ ("CC" "gcc") ("--global-option"
+("--some-global-option")) ("--build-option" ("--build-option1"
+"--build-option2")))}
+@item
+@code{#:backend-path} is added. It defaults to @code{#false}, but when
+set to a list it will be appended to Python’s search path and overrides
+the definition in @file{pyproject.toml}.
+@item
@code{#:build-backend} is added. It defaults to @code{#false} and will try
to guess the appropriate backend based on @file{pyproject.toml}.
@item