summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-21 15:05:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:05:38 +0200
commit0f55ba02f81091d82f4d0f3376cf31cf83e772f3 (patch)
tree633f0caf93f33bcc665b96990b38b5a83da64f7c
parente17242bb9125b736e601a06c02ee3ba06bc7483b (diff)
gnu: cargo-machete: Update to 0.7.0.
* gnu/packages/rust-apps.scm (cargo-machete): Update to 0.7.0. [arguments]: Don't skip the tests. Add cargo-test-flags. [cargo-inputs]: Add rust-ignore-0.4. Replace rust-cargo-toml-0.19 with 0.20. [home-page]: Update to new home-page. Change-Id: I2024b9a104b772a7dee7945c1dbb5e10b9f0bc9a
-rw-r--r--gnu/packages/rust-apps.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 149c4258e3e..19d2c4a1f51 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -369,30 +369,44 @@ paging.")
(define-public cargo-machete
(package
(name "cargo-machete")
- (version "0.6.2")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (crate-uri name version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0n45j6q36zjw149a84wz2yyygfhcjsnvfaiskwph00684fzlbnbm"))))
+ (base32 "0ha5z1xr26mjprk4vbiy2v9wcwr7ww2jxiamlc8fqwi3d5hvhk1n"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ;Error: No such file or directory (os error 2)
+ `(#:cargo-test-flags
+ '("--release" "--"
+ "--skip=search_unused::test_crate_renaming_works"
+ "--skip=search_unused::test_false_positive_macro_use"
+ "--skip=search_unused::test_ignore_deps_works"
+ "--skip=search_unused::test_ignore_deps_workspace_works"
+ "--skip=search_unused::test_just_unused"
+ "--skip=search_unused::test_just_unused_with_manifest"
+ "--skip=search_unused::test_unused_kebab_spec"
+ "--skip=search_unused::test_unused_renamed_in_registry"
+ "--skip=search_unused::test_unused_renamed_in_spec"
+ "--skip=search_unused::test_unused_transitive"
+ "--skip=search_unused::test_with_bench"
+ "--skip=test_ignore_target")
#:install-source? #f
#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
("rust-argh" ,rust-argh-0.1)
("rust-cargo-metadata" ,rust-cargo-metadata-0.18)
- ("rust-cargo-toml" ,rust-cargo-toml-0.19)
+ ("rust-cargo-toml" ,rust-cargo-toml-0.20)
("rust-grep" ,rust-grep-0.3)
+ ("rust-ignore" ,rust-ignore-0.4)
("rust-log" ,rust-log-0.4)
("rust-pretty-env-logger" ,rust-pretty-env-logger-0.5)
("rust-rayon" ,rust-rayon-1)
("rust-serde" ,rust-serde-1)
("rust-toml-edit" ,rust-toml-edit-0.22)
("rust-walkdir" ,rust-walkdir-2))))
- (home-page "https://github.com/est31/cargo-udeps")
+ (home-page "https://github.com/bnjbvr/cargo-machete")
(synopsis "Find unused dependencies in Cargo.toml")
(description "@code{cargo-machete} finds unused dependencies in Cargo.toml.")
(license (list license:expat license:asl2.0))))