summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-01 12:26:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-01 14:55:08 +0200
commit0aae7c333d1e90c4b5bd4f522d35f1ece1c6ecbf (patch)
tree30cd6549cdd2ca0417fb2f441acca5ddebeb1492
parent2790f7b437ddfd09d17a61cd795e004da9d2ea08 (diff)
gnu: libfabric: Check for transitive supported packages.
* gnu/packages/linux.scm (libfabric)[inputs]: Adjust if-supported function to check the package-transitive-supported-systems. Change-Id: I47d14b08906753d20f6f2a7ab4068a9e84319350
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6eecfb46b3..db703d5d1c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9134,11 +9134,11 @@ known as Slingshot.")
(base32 "1znmw83rmippv0fwz0x7lgylfk17dr9ckll8lrm4z7kclspnqpj8"))))
(build-system gnu-build-system)
(inputs
- (let ((if-supported ;XXX: copied from openmpi
+ (let ((if-supported ;XXX: modified from openmpi
(lambda (package . extra)
(if (and (not (%current-target-system))
(member (%current-system)
- (package-supported-systems package)))
+ (package-transitive-supported-systems package)))
(cons package extra)
'()))))
(append (list rdma-core libnl)