summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRunciter <runciter@whispers-vpn.org>2024-12-01 20:59:35 +0000
committerLudovic Courtès <ludo@gnu.org>2024-12-02 23:18:52 +0100
commit0a5e626f106b569c6c087da38385fc020fe1defd (patch)
tree651bd4331f5271a8af72047327be968516a7d3b4
parent58a8d3b180e3130bcbc9c371836d411474aa0c96 (diff)
gnu: Add (gnu packages dictd).
* gnu/packages/dictd.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I3b68fbbed0a7a44287a6eda6c1e66e068fa17b8f
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/dictd.scm63
2 files changed, 65 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1b699af259a..df416953617 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -68,6 +68,7 @@
# Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
# Copyright © 2024 Fabio Natali <me@fabionatali.com>
# Copyright © 2024 Noé Lopez <noelopez@free.fr>
+# Copyright © 2024 Runciter <runciter@whispers-vpn.org>
#
# This file is part of GNU Guix.
#
@@ -241,6 +242,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/decker.scm \
%D%/packages/dhall.scm \
%D%/packages/dico.scm \
+ %D%/packages/dictd.scm \
%D%/packages/dictionaries.scm \
%D%/packages/diffoscope.scm \
%D%/packages/digest.scm \
diff --git a/gnu/packages/dictd.scm b/gnu/packages/dictd.scm
new file mode 100644
index 00000000000..8e025a2f04b
--- /dev/null
+++ b/gnu/packages/dictd.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Runciter <runciter@whispers-vpn.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dictd)
+ #:use-module (guix packages)
+ #:use-module (guix gexp)
+ #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages autotools))
+
+(define-public libmaa
+ (package
+ (name "libmaa")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/dict/libmaa/"
+ "libmaa-"
+ version
+ "/libmaa-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "1idi4c30pi79g5qfl7rr9s17krbjbg93bi8f2qrbsdlh78ga19ar"))))
+ (native-inputs (list libtool))
+ (arguments
+ (list
+ ;; Change -Werror to -Wno-error, reproduce other default flags
+ ;; Do not error out on warnings related to snprintf function
+ #:make-flags #~'("CFLAGS=-DHAVE_CONFIG_H -Wall -Wno-error -g -O2 $(VERCFLAGS) -I. -I${srcdir}")
+ #:test-target "test"))
+ (build-system gnu-build-system)
+ (synopsis "Low-level data structures used by the dictd program")
+ (description
+ "The libmaa library provides many low-level
+data structures which are helpful for writing compilers, including hash
+tables, sets, lists, debugging support, and memory management. Although
+libmaa was designed and implemented as a foundation for the Khepara
+transformation system, the data structures are generally applicable to a
+wide range of programming problems.
+
+The memory management routines are especially helpful for improving the
+performance of memory-intensive applications.")
+ (home-page "https://sourceforge.net/projects/dict/")
+ (license gpl2+)))