summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-10-15 20:46:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-10-18 11:16:28 +0200
commit061e0acd596262420facef7c2d1fc9cc4327d75a (patch)
tree487b62c342f85f50dd69b2b8b670f949806add66
parentc2edd382ba0325fdb7b74393856c6826b824f1f1 (diff)
gnu: infamous-plugins: Update to 0.3.2.
* gnu/packages/audio.scm (infamous-plugins): Update to 0.3.2. [arguments]: Remove obsolete build phase 'fix-build-with-newer-lv2. Change-Id: Ic483d42c9d9558d9e047040e64817fcb0c0ca7c2
-rw-r--r--gnu/packages/audio.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5639d6b0d0..4fde88d454 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1420,7 +1420,7 @@ time, using templates, instead of calling @code{malloc()} or @code{new}.")
(define-public infamous-plugins
(package
(name "infamous-plugins")
- (version "0.3.0")
+ (version "0.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1429,7 +1429,7 @@ time, using templates, instead of calling @code{malloc()} or @code{new}.")
(file-name (git-file-name name version))
(sha256
(base32
- "1r72agk5nxf5k0mghcc2j90z43j5d9i7rqjmf49jfyqnd443isip"))))
+ "1ay66lly6bgqr3nzb0y4b29rgl5y1slk6wf73kr3xiw2p62bh582"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -1438,14 +1438,7 @@ time, using templates, instead of calling @code{malloc()} or @code{new}.")
(add-after 'unpack 'remove-compiler-flags
(lambda _
(substitute* (find-files "." "CMakeLists.txt")
- (("-msse2 -mfpmath=sse") ""))
- #t))
- (add-after 'unpack 'fix-build-with-newer-lv2
- (lambda _
- ;; https://github.com/ssj71/infamousPlugins/commit/4c7275b1fa8ea3296446421cbd29ec2df66588c0
- (substitute* (find-files "src" ".*\\.cxx")
- (("_LV2UI_Descriptor") "LV2UI_Descriptor"))
- #t)))))
+ (("-msse2 -mfpmath=sse") "")))))))
(inputs
(list cairo fftwf lv2 ntk zita-resampler))
(native-inputs