summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-09-03 20:32:32 +0000
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-09-09 18:58:27 +0800
commit0222cd0c8b07a193f32641fa30a29008e5154eef (patch)
tree1a2ddcc2374b10435e9d48ef9093db88c2339155
parentb82c8ceae14d5d0f4584452f34f5103ffd0e0f8d (diff)
gnu: Add fmt-11.
* gnu/packages/pretty-print.scm (fmt-11): New variable. (fmt-10): Inherit from fmt-11. Change-Id: Ic9f28cfb5a805f33beaad9794d69f992a5a27652 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
-rw-r--r--gnu/packages/pretty-print.scm27
1 files changed, 20 insertions, 7 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index d8ff1664b4..ca98694afa 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -170,20 +170,20 @@ It also includes the capability to perform syntax highlighting for several
different programming languages.")
(license gpl3+)))
-(define-public fmt-10
+(define-public fmt-11
(package
(name "fmt")
- (version "10.2.1")
+ (version "11.0.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
- version "/fmt-" version ".zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmtlib/fmt")
+ (commit version)))
(sha256
- (base32 "1j8nln7rql2nxkhdlgpmx1c1dp6dyxnar1n5r7sjg0rws6i5289i"))))
+ (base32 "1v9k57zj34axagkxwkmg73gs9h15i6c8nv9hsgwjwmi82pinv8r0"))))
(build-system cmake-build-system)
(arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
- (native-inputs (list unzip))
(home-page "https://fmt.dev")
(synopsis "Small and fast C++ formatting library")
(description "@code{fmt} (formerly @code{cppformat}) is a formatting
@@ -192,6 +192,19 @@ a fast alternative to @code{IOStreams}.")
;; The library is bsd-2, but documentation and tests include other licenses.
(license (list bsd-2 bsd-3 psfl))))
+(define-public fmt-10
+ (package
+ (inherit fmt-11)
+ (version "10.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+ version "/fmt-" version ".zip"))
+ (sha256
+ (base32 "1j8nln7rql2nxkhdlgpmx1c1dp6dyxnar1n5r7sjg0rws6i5289i"))))
+ (native-inputs (list unzip))))
+
(define-public fmt-9
(package
(inherit fmt-10)