summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-11-29 08:31:31 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-12-08 14:10:52 +0100
commitfe0b1aea1fd02809043d8c0793088bb8b3db2cea (patch)
tree5e5864f7515883742ebda0a56bb6d7cd90d65baa
parentc01730199d971e932901c35f627656bffe876f86 (diff)
gnu: Add python-clingexplaid.
* gnu/packages/potassco.scm (python-clingexplaid): New variable.
-rw-r--r--gnu/packages/potassco.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index ec990f1382..57caf6aabc 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -756,3 +756,36 @@ but also works fine along custom-built test. Clintest monitors the test
outcome while solving to abort the search for solutions once the outcome is
certain.")
(license license:expat)))
+
+(define-public python-clingexplaid
+ (package
+ (name "python-clingexplaid")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/clingo-explaid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s80cs3clvz26r7cvjprlk6zip7yqswwhzzwmmrv5mf5p89ymrgm"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags #~(list "-k" "not test_main")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pyproject-toml
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("dynamic = .*" all)
+ (string-append "version = \""
+ #$version
+ "\"\n"))
+ (("\"autoflake\",") "")))))))
+ (propagated-inputs (list python-clingo))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/potassco/clingo-explaid")
+ (synopsis "Develop explanation systems with Clingo")
+ (description "This package provides tools to develop explanation systems
+with clingo. It allows extracting minimal unsatisfiable subsets and
+unsatisfiable constraints.")
+ (license license:expat)))