summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 11:56:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:45 +0000
commitdc1b7e1828ba3f3aec3cdee9cb7976b6cc98bcf7 (patch)
tree6ff18a2e9285d56d90f21599cbe1d5987c60acdd
parent838d28253065b268c026e7eb84dd2e3cede666ab (diff)
gnu: go-github-com-google-uuid: Move to golang-build.
* gnu/packages/golang.scm (go-github-com-google-uuid): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: Ie32c2ab29a0b7a1bbb7d63d40338d0a7a0bca988
-rw-r--r--gnu/packages/golang-build.scm24
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 5c2f3efbbc..c7bed8133f 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -249,6 +249,30 @@ replace a file or symbolic link.")
(list
#:import-path "github.com/google/renameio/v2"))))
+(define-public go-github-com-google-uuid
+ (package
+ (name "go-github-com-google-uuid")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/uuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "131d01minir79dq6d4jq55018343yidl5cs2bfhynx1klnr7ssam"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/google/uuid"))
+ (home-page "https://github.com/google/uuid/")
+ (synopsis "Generate and inspect UUIDs based on RFC 4122 and DCE 1.1")
+ (description
+ "The uuid package generates and inspects UUIDs based on RFC 4122 and DCE
+1.1: Authentication and Security Services.")
+ (license license:bsd-3)))
+
(define-public go-github-com-yuin-goldmark
(package
(name "go-github-com-yuin-goldmark")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 308831bcb4..9e0e8eff66 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5290,28 +5290,6 @@ a cron spec parser and job runner.")
"This is a fork of another go-libvterm library for use with aerc.")
(license license:expat))))
-(define-public go-github-com-google-uuid
- (package
- (name "go-github-com-google-uuid")
- (version "1.6.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/uuid")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "131d01minir79dq6d4jq55018343yidl5cs2bfhynx1klnr7ssam"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/uuid"))
- (home-page "https://github.com/google/uuid/")
- (synopsis "Generate and inspect UUIDs based on RFC 4122 and DCE 1.1")
- (description "The uuid package generates and inspects UUIDs based on RFC
-4122 and DCE 1.1: Authentication and Security Services.")
- (license license:bsd-3)))
-
(define-public go-github-com-google-gopacket
(package
(name "go-github-com-google-gopacket")