summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-27 20:42:09 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:39 +0000
commitd3bad46f990fbd884ca114dddd5af0eae434aecc (patch)
tree789d2bacb2a62dbcea8a7420cec987a9a60f49e6
parented9935ff8723186a906629b576b70dd54e62f7d4 (diff)
gnu: reprotest: Improve package style
* gnu/packages/diffoscope.scm (reprotest): Improve package style, adjust fields order. [build-system]: Swap to pyproject-build-system. [inputs]: Remove python-debian, python-distro, python-libarchive-c, and python-rstr. [propagated-inputs]: Add python-debian, python-distro, python-libarchive-c, and python-rstr. [native-inputs]: Remove python-coverage and python-tox, add python-setuptools and python-wheel. Change-Id: Ia99f4a512c543bde2d9e4caba7dfecee2c05701e
-rw-r--r--gnu/packages/diffoscope.scm49
1 files changed, 29 insertions, 20 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 5aaa64fbb8..c08c5351ce 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages patchutils)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -65,6 +66,7 @@
#:use-module (gnu packages vim)
#:use-module (gnu packages web)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -263,36 +265,43 @@ install.")
(file-name (git-file-name name version))
(sha256
(base32 "06jm82w05qsx3wskch3fm5mpkpj5jmq7r4yram4ixprxc5j8flg8"))))
- (inputs
- (list python-debian python-distro python-libarchive-c python-rstr))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; TODO: all tests failed during creation: PermissionError: [Errno 13]
+ ;; Permission denied.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (let* ((mandir1 (string-append
+ #$output "/share/man/man1"))
+ (docdir (string-append
+ #$output "/share/doc/" #$name "-" #$version)))
+ (invoke "make" "-C" "doc")
+ (mkdir-p mandir1)
+ (install-file "doc/reprotest.1" mandir1)
+ (mkdir-p docdir)
+ (install-file "./README.rst" docdir)
+ (install-file "./README-dev.rst" docdir)))))))
(native-inputs
(list diffoscope
help2man
libfaketime
- python-coverage
python-docutils
python-magic
python-pytest
+ python-setuptools
python-tlsh
- python-tox
+ python-wheel
unzip
xxd))
- (build-system python-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda _
- (let* ((mandir1 (string-append
- #$output "/share/man/man1"))
- (docdir (string-append
- #$output "/share/doc/" #$name "-" #$version)))
- (invoke "make" "-C" "doc")
- (mkdir-p mandir1)
- (install-file "doc/reprotest.1" mandir1)
- (mkdir-p docdir)
- (install-file "./README.rst" docdir)
- (install-file "./README-dev.rst" docdir)))))))
+ (propagated-inputs
+ (list python-debian
+ python-distro
+ python-libarchive-c
+ python-rstr))
(home-page "https://salsa.debian.org/reproducible-builds/reprotest")
(synopsis "Build software and check it for reproducibility")
(description "Reprotest builds the same source code twice in different