summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-01-14 16:03:22 +0800
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:51 +0100
commita9dec56b8556ad8b5416f6ed8ca62f9c0980f311 (patch)
tree8b52db5fff16e000436c56a455d481a4f9cacaab
parent9ac87191fe98c80aac21dd8347ea39ee3c46fcb6 (diff)
gnu: python-pytest-ordering: Switch to maintained fork pytest-order.
* gnu/packages/python-check.scm (python-pytest-ordering): Remove variable. (python-pytest-order): New variable. Change-Id: I094575b90363e8286f26f184bcf02ecd25c8994e
-rw-r--r--gnu/packages/python-check.scm35
1 files changed, 13 insertions, 22 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 3a167a76b58..17acfd2997b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -704,34 +704,25 @@ interactions, which will update them to correspond to the new API.")
through Python's socket interface")
(license license:expat)))
-(define-public python-pytest-ordering
+(define-public python-pytest-order
(package
- (name "python-pytest-ordering")
- (version "0.6")
+ (name "python-pytest-order")
+ (version "1.3.0")
(source
(origin
- ;; No tests in the PyPI tarball.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ftobia/pytest-ordering")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (pypi-uri "pytest_order" version))
(sha256
- (base32 "14msj5gyqza0gk3x7h1ivmjrwza82v84cj7jx3ks0fw9lpin7pjq"))))
- (build-system python-build-system)
+ (base32 "1pixy83l6hcg16gjc04vp4misk2w989alkd9msnw1s9y7pn8yq2i"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-k"
- ;; This test fails because of a type mismatch of an
- ;; argument passed to @code{pytest.main}.
- "not test_run_marker_registered"))))))
+ (list
+ ;; XXX: 4 failed, 18 errors
+ #:tests? #f))
(native-inputs
- (list python-pytest))
- (home-page "https://github.com/ftobia/pytest-ordering")
+ (list python-pytest python-pytest-xdist
+ python-setuptools python-wheel))
+ (home-page "https://github.com/pytest-dev/pytest-order")
(synopsis "Pytest plugin to run your tests in a specific order")
(description
"This plugin defines Pytest markers to ensure that some tests, or groups