summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-23 01:42:15 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:42:18 +0000
commit8d903eff2f2abfcbb811182e6058eb144664dfc2 (patch)
treea12e0dbf9dbf81aa5199eacb189746e13be5280d
parent60469b0116a46b5585aec5372cf3d2f3a970dc48 (diff)
gnu: exercism: Update to 3.5.4.
* gnu/packages/education.scm (exercism): Update to 3.5.4. * gnu/packages/patches/exercism-disable-self-update.patch: Refresh it to be compatible. Change-Id: Ia1920522d232fa681b70178bce2220649b0bcbe0
-rw-r--r--gnu/packages/education.scm4
-rw-r--r--gnu/packages/patches/exercism-disable-self-update.patch15
2 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index f0ff95b2871..021c7334601 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -1112,7 +1112,7 @@ machine, and more.")
(define-public exercism
(package
(name "exercism")
- (version "3.1.0")
+ (version "3.5.4")
(source
(origin
(method git-fetch)
@@ -1122,7 +1122,7 @@ machine, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ah5v4pqq31bvj7s4rg3jyjn7jwxa15w31cn4c317gsqmi0n8rzl"))
+ "0shh84g7j977kn9kcm09rj3lz6a3y5qq9yvklsldgb9zvass5szd"))
(patches (search-patches "exercism-disable-self-update.patch"))))
(build-system go-build-system)
(arguments
diff --git a/gnu/packages/patches/exercism-disable-self-update.patch b/gnu/packages/patches/exercism-disable-self-update.patch
index a96cbfbc55a..0827e5102b8 100644
--- a/gnu/packages/patches/exercism-disable-self-update.patch
+++ b/gnu/packages/patches/exercism-disable-self-update.patch
@@ -1,21 +1,23 @@
-From bc22f7d43c12c5f79c71b0319666e71f29d61322 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jakub=20K=C4=85dzio=C5=82ka?= <kuba@kadziolka.net>
-Date: Mon, 25 May 2020 18:53:04 +0200
+From a0e422b11a65d63bd435c96bee3cd08f06bb8ec8 Mon Sep 17 00:00:00 2001
+From: Sharlatan Hellseher <sharlatanus@gmail.com>
+Date: Mon, 23 Dec 2024 01:59:10 +0000
Subject: [PATCH] Disable self-update.
+For exercism cli V3.5.4.
+
Based on a Fedora patch by Elliott Sales de Andrade.
---
cli/cli.go | 44 +-------------------------------------------
1 file changed, 1 insertion(+), 43 deletions(-)
diff --git a/cli/cli.go b/cli/cli.go
-index 4312eb0..5f62297 100644
+index fe113ec..3baa4b0 100644
--- a/cli/cli.go
+++ b/cli/cli.go
@@ -10,13 +10,10 @@ import (
"io"
- "io/ioutil"
"net/http"
+ "os"
- "runtime"
"strings"
"time"
@@ -75,5 +77,4 @@ index 4312eb0..5f62297 100644
func (c *CLI) fetchLatestRelease() error {
--
-2.26.2
-
+2.46.0