summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-10 10:16:05 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-10 13:41:38 +0100
commit832ef198f7e423e0fdff7fe7c5558ff13d1f20c1 (patch)
tree990b52d3e975c63a9201558e5589cc82c5c7480a
parent93e1586116f39a30ba1fcb67bd839a43533dfaf4 (diff)
guile: Silence GC warnings on the Hurd, part II.
This is a follow-up to commit b0416b8503e38746717a2d1167f9d1410634981e guile: Silence GC warnings on the Hurd. This should work around <https://issues.guix.gnu.org/73181>, resurrecting offloading to the Hurd. * gnu/packages/aux-files/guile-launcher.c: (main)[__GNU__]: Move code to silence warnings to... (inner_main)[__GNU__]: ...here. Change-Id: I408201f7f4072c9a33837e6020ac63270b33702e
-rw-r--r--gnu/packages/aux-files/guile-launcher.c16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/aux-files/guile-launcher.c b/gnu/packages/aux-files/guile-launcher.c
index bc7fa21b635..c205477f649 100644
--- a/gnu/packages/aux-files/guile-launcher.c
+++ b/gnu/packages/aux-files/guile-launcher.c
@@ -43,6 +43,14 @@ static const char *load_path, *load_compiled_path;
static void
inner_main (void *unused, int argc, char **argv)
{
+#if defined __GNU__
+ /* XXX: On 32-bit GNU/Hurd (i586-gnu), libgc emits "Repeated allocation"
+ warnings that are annoying and interfere with communications between
+ 'guix-daemon' and 'guix authenticate':
+ <https://issues.guix.gnu.org/73181>. Silence them. */
+ GC_set_warn_proc (no_warnings);
+#endif
+
if (load_path != NULL)
{
setenv ("GUILE_LOAD_PATH", load_path, 1);
@@ -82,14 +90,6 @@ main (int argc, char **argv)
which is always preferable over the C locale. */
setlocale (LC_ALL, "en_US.utf8");
-#if defined __GNU__
- /* XXX: On 32-bit GNU/Hurd (i586-gnu), libgc emits "Repeated allocation"
- warnings that are annoying and interfere with communications between
- 'guix-daemon' and 'guix authenticate':
- <https://issues.guix.gnu.org/73181>. Silence them. */
- GC_set_warn_proc (no_warnings);
-#endif
-
const char *str;
str = getenv ("GUILE_LOAD_PATH");
load_path = str != NULL ? strdup (str) : NULL;