summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2024-12-29 17:10:22 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-12-30 17:20:08 +0800
commit48604156348b2def0e1981531d53635a63cfc0e5 (patch)
tree8bb5e04ab4d9cb4fe4162b8aa9708767e66a4d80
parentfb21b316105ebba350eff8311c7b4ff682a7b63b (diff)
gnu: endless-sky: Update to 0.10.10.
* gnu/packages/games.scm (endless-sky): Update to 0.10.10. [inputs]: Add catch2-3. Change-Id: I1ef88580c0b30169d7c3d9fae7c6c792ad1fa43a Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5521b9b14f..4608b8d2e8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9222,7 +9222,7 @@ your score gets higher, you level up and the blocks fall faster.")
(define-public endless-sky
(package
(name "endless-sky")
- (version "0.10.6")
+ (version "0.10.10")
(source
(origin
(method git-fetch)
@@ -9231,7 +9231,7 @@ your score gets higher, you level up and the blocks fall faster.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1iaiyv9fqgg269wjcyfn1akhh0wfrf64gh5jg3wzxwn24pm77flw"))))
+ (base32 "1nwim56ii3z6f9gxvmf9q4i5chlsgk3kjisz8li6ivr595wq5502"))))
(build-system cmake-build-system)
(arguments
(list #:configure-flags #~(list "-DES_USE_VCPKG=0"
@@ -9249,7 +9249,8 @@ your score gets higher, you level up and the blocks fall faster.")
(substitute* "CMakeLists.txt"
(("games\\)") "bin)")))))))
(inputs
- (list glew
+ (list catch2-3
+ glew
libjpeg-turbo
libmad
libpng