summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 17:18:28 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:13 +0800
commit4685859e20725f6cf1f2a395808b2e643b42d07d (patch)
tree5de819695f57db30466d3915e385f3a2c50bbbaf
parent11a31d452d45b17bb4f6caa1a44aa232f2f829e6 (diff)
gnu: falkon: Update to 24.05.2.
* gnu/packages/kde-internet.scm (falkon): Update to 24.05.2. [arguments]<#:phases>: Stop replace check phase, Add wrap phase. [inputs]: Remove qtquickcontrols-5, qtsvg-5, qtwebengine-5, qtx11extras, and qtwayland-5; add qt5compat, qtsvg, qtwebengine, and qtwayland. [native-inputs]: Remove qttools-5; add qttools. Change-Id: Ie14f2889acdd4424d8b846cca9faf85c6488a3e1
-rw-r--r--gnu/packages/kde-internet.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index f05ab908994..d8fc2e1161a 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -118,7 +119,7 @@ Other notable features include:
(define-public falkon
(package
(name "falkon")
- (version "23.04.3")
+ (version "24.05.2")
(source
(origin
(method url-fetch)
@@ -126,18 +127,23 @@ Other notable features include:
"/src/falkon-" version ".tar.xz"))
(sha256
(base32
- "11r1iwimdzabfah68gsvw6xi67cj539anqa6s1rg33agsi5y56d3"))))
+ "0j930i2nvg71p05z881inbk59c54gx8dzhyjb8iaqkw8i5s5r983"))))
(build-system qt-build-system)
(arguments
(list #:phases
#~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "ctest" "-E"
- "(locationbartest|qmltabsapitest)")))))))
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((qtwebengineprocess
+ (search-input-file inputs
+ "lib/qt6/libexec/QtWebEngineProcess")))
+ ;; The program fails to find the QtWebEngineProcess program, so
+ ;; we set QTWEBENGINEPROCESS_PATH to help it.
+ (wrap-program (string-append #$output "/bin/falkon")
+ `("QTWEBENGINEPROCESS_PATH" =
+ (,qtwebengineprocess)))))))))
(native-inputs
- (list extra-cmake-modules pkg-config qttools-5))
+ (list extra-cmake-modules pkg-config qttools))
(inputs
(list karchive
kcoreaddons
@@ -147,11 +153,10 @@ Other notable features include:
kwallet
openssl
purpose
- qtquickcontrols-5
- qtsvg-5
- qtwebengine-5
- qtx11extras
- qtwayland-5
+ qt5compat
+ qtsvg
+ qtwebengine
+ qtwayland
xcb-util))
(home-page "https://www.falkon.org/")
(synopsis "Qt-based web browser for KDE")