summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRon Nazarov <ron@noisytoot.org>2024-11-18 12:53:38 +0000
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-20 18:24:24 +0800
commit39d1acc0212f286de4c34e76f96fa1d5efd132df (patch)
tree108bf211005039c62a732372503ad5e72ce1aca8
parentefb386dd3a4aa736d8d26cc02b2c1bb78ca915a0 (diff)
gnu: qbittorrent: Update to 5.0.1.
* gnu/packages/bittorrent.scm (qbittorrent): Update to 5.0.1. [arguments]: Set #:qtbase to qtbase. [native-inputs]: Replace qttools-5 with qttools. [inputs]: Replace qtsvg-5 with qtsvg. Change-Id: I82dd5b65f1a812c989baa752313cd3daeaf0d8bf
-rw-r--r--gnu/packages/bittorrent.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 2b38c7cb65..0c24af2764 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Jacob Hart <hartja1@yahoo.com>
;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2024 Noisytoot <ron@noisytoot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -510,7 +511,7 @@ desktops.")
(define-public qbittorrent
(package
(name "qbittorrent")
- (version "4.6.6")
+ (version "5.0.1")
(source
(origin
(method git-fetch)
@@ -519,19 +520,20 @@ desktops.")
(commit (string-append "release-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0kv7dgnfy8m480kxc4na9v9cjq9f9m3il191w7yvj4i8lz6jcaq1"))))
+ (base32 "03kqir7jyrzblg4642gnf2pp8f0x68njgaalmq8qjh7dcx0d6rq6"))))
(build-system qt-build-system)
(arguments
- (list #:configure-flags #~(list "-DTESTING=ON")
+ (list #:qtbase qtbase
+ #:configure-flags #~(list "-DTESTING=ON")
#:test-target "check"))
(native-inputs
- (list qttools-5))
+ (list qttools))
(inputs
(list boost
libtorrent-rasterbar
openssl
python-wrapper
- qtsvg-5
+ qtsvg
zlib))
(home-page "https://www.qbittorrent.org/")
(synopsis "Graphical BitTorrent client")