summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-06-18 13:26:16 +0200
committerChristopher Baines <mail@cbaines.net>2024-07-15 22:34:25 +0100
commit21bf76c5639952ca6ee8de171739e9521a74f924 (patch)
tree083263c09fadf25feeb658942996bf9761a375ff
parent17188be0f723e00377b21b767f5447d7938a116e (diff)
gnu: mingw-w64-tools: Use G-Expressions.
* gnu/packages/mingw.scm (mingw-w64-tools): Use G-Expressions. Change-Id: I690d0aeae6c6920d2e3eb43732d6b421a3dfc59b Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/mingw.scm74
1 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 8a8a8854466..c0a258091c3 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -162,45 +162,45 @@ several new APIs such as DirectX and DDK, and 64-bit support.")
(base32 "047f4m37kxf7g8qj23qplrzfd9cirfkkv8d175sfv2zfd7hbqriz"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
+ (list
+ #:modules '((guix build gnu-build-system)
(guix build utils)
(srfi srfi-1))
- #:phases
- (append
- (modify-phases %standard-phases
- (add-after 'unpack 'cd-gendef
- (lambda _
- (chdir "mingw-w64-tools/gendef"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genidl"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genlib"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genpeimg"))))
- (append-map
- (lambda (target)
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../widl")
- (false-if-exception
- (delete-file-recursively "../build"))
- #t))
- (replace 'configure
- (lambda args
- (apply (assoc-ref %standard-phases 'configure)
- (append args (list #:out-of-source? #t
- #:configure-flags
- `("--target" ,target
- "--program-prefix"
- ,(string-append target "-")))))))))
- '("i686-w64-mingw32" "x86_64-w64-mingw32")))))
+ #:phases
+ #~(append
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cd-gendef
+ (lambda _
+ (chdir "mingw-w64-tools/gendef"))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../genidl"))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../genlib"))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../genpeimg"))))
+ (append-map
+ (lambda (target)
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../widl")
+ (false-if-exception
+ (delete-file-recursively "../build"))))
+ (replace 'configure
+ (lambda args
+ (apply (assoc-ref %standard-phases 'configure)
+ (append args (list #:out-of-source? #t
+ #:configure-flags
+ `("--target" ,target
+ "--program-prefix"
+ ,(string-append target "-")))))))))
+ '("i686-w64-mingw32" "x86_64-w64-mingw32")))))
(home-page "https://mingw-w64.org")
(synopsis "Tools of Minimalist GNU for Windows")
(description "This package provides the tools of Minimalist GNU for