summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2025-01-02 10:11:22 -0600
committerjgart <jgart@dismail.de>2025-01-02 10:20:43 -0600
commit20089e244902717eafd5b90ab76ef0704ba1695f (patch)
tree8e1c6928d76a51e97eefdf46aae1883c3d4edad3
parent183f330905e8da0575353628ffd51fcdbb46844f (diff)
gnu: Remove python-pyls-black.
* gnu/packages/python-xyz.scm (python-pyls-black): Delete variable and remove associated patch. Project is no longer maintained as of 4 years to this date and has been succeeded and forked by python-lsp-black. Change-Id: Ic209f23e6368744db74b93e2a9c01a9859b04f82
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pyls-black-41.patch45
-rw-r--r--gnu/packages/python-xyz.scm45
3 files changed, 0 insertions, 91 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 02a6fa616e..aa7b3ed6ba 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1983,7 +1983,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pillow-use-zlib-1.3.patch \
%D%/packages/patches/python-pydocstyle-add-support-for-pep701.patch \
%D%/packages/patches/python-pyreadstat-link-libiconv.patch \
- %D%/packages/patches/python-pyls-black-41.patch \
%D%/packages/patches/python-sip-include-dirs.patch \
%D%/packages/patches/python-sgmllib3k-assertions.patch \
%D%/packages/patches/python-sphobjinv-defer-ssl-import.patch \
diff --git a/gnu/packages/patches/python-pyls-black-41.patch b/gnu/packages/patches/python-pyls-black-41.patch
deleted file mode 100644
index 5a1ebd2f54..0000000000
--- a/gnu/packages/patches/python-pyls-black-41.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From ada6a999e4f5cca21a2133e449f4576dbe9a64d2 Mon Sep 17 00:00:00 2001
-From: Isaac Dadzie <4581114+idadzie@users.noreply.github.com>
-Date: Fri, 4 Feb 2022 21:18:37 +0000
-Subject: [PATCH] Add support for black 22.1.0
-
-Make changes to support black 22.1.0, which changed the return type
-of 'find_project_root' to a tuple.
-
-Resolves: #40
----
- pyls_black/plugin.py | 8 +++++++-
- setup.cfg | 2 +-
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/pyls_black/plugin.py b/pyls_black/plugin.py
-index dc5d482..e4f4d98 100644
---- a/pyls_black/plugin.py
-+++ b/pyls_black/plugin.py
-@@ -73,7 +73,13 @@ def load_config(filename: str) -> Dict:
-
- root = black.find_project_root((filename,))
-
-- pyproject_filename = root / "pyproject.toml"
-+ # Note: find_project_root returns a tuple in 22.1.0+
-+ try:
-+ # Keeping this to not break backward compatibility.
-+ pyproject_filename = root / "pyproject.toml"
-+ except TypeError:
-+ _root, _ = root
-+ pyproject_filename = _root / "pyproject.toml"
-
- if not pyproject_filename.is_file():
- return defaults
-diff --git a/setup.cfg b/setup.cfg
-index 036cec2..57fbe4f 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -1,6 +1,6 @@
- [metadata]
- name = pyls-black
--version = 0.4.7
-+version = 0.4.8
- author = Rupert Bedford
- author_email = rupert@rupertb.com
- description = Black plugin for the Python Language Server
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a922ebbb30..49a7035e99 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3364,51 +3364,6 @@ Unicode-to-LaTeX conversion.")
"Mypy linter integration for use with @code{python-lsp-server}.")
(license license:expat)))
-(define-public python-pyls-black
- (package
- (name "python-pyls-black")
- (version "0.4.7")
- (source
- (origin
- ;; There are no tests in the PyPI tarball.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rupert/pyls-black/")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0bkhfnlik89j3yamr20br4wm8975f20v33wabi2nyxvj10whr5dj"))
- (patches (search-patches "python-pyls-black-41.patch"))
- ;; Patch to work with python-lsp-server. Taken from
- ;; <https://github.com/rupert/pyls-black/pull/37>.
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "setup.cfg"
- (("python-language-server")
- "python-lsp-server"))
- (substitute* '("pyls_black/plugin.py" "tests/test_plugin.py")
- (("pyls_format_document")
- "pylsp_format_document")
- (("pyls_format_range")
- "pylsp_format_range")
- (("from pyls([ \\.])" _ char)
- (string-append "from pylsp" char)))))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- '(list "-k" "not test_load_config_target_version")))
- (propagated-inputs
- (list python-black python-lsp-server python-toml python-tomli))
- (native-inputs
- (list python-flake8 python-isort python-mypy python-pytest
- python-pytest-runner python-setuptools python-wheel))
- (home-page "https://github.com/rupert/pyls-black")
- (synopsis "Black plugin for the Python Language Server")
- (description "Black plugin for the Python Language Server.")
- (license license:expat)))
-
(define-public python-sh
(package
(name "python-sh")